Cannot create texture for TCanvasD2D

Receiving the above error message when trying to print Ancester Chart, Descendant List, and Family Group Sheet. Result is an empty sheet and a box with this error message. When I click OK, all the command boxes disappear unless I hover over them (screen is black). Updated to 9.1.6 this morning. Restarted RM 9 twice. Using desktop Windows 12 machine. When I restarted the program, all the command boxes reappeared, only to encounter the same error. Thanks!

Are you beta testing Windows 12?

My bad. I am on Windows 11 Home. Good catch!

First, I want to make sure your database isn’t inside of a folder syncing with the cloud, like OneDrive, Dropbox or Google Drive. I’ve seen command boxes disappear in those cases. Otherwise, it could be a resources issue and your graphic card with items disappearing. When you are printing it is to your printer, OneNote, or something else?

It’s saving to My Documents, on my hard drive…not the cloud. I tried printing a hard copy and then as a pdf but got the same error message. Since my last reply, I restarted my PC and redid the same steps and got the same error message. This is the first time I have had this problem and I’ve been using RM9 since the beginning, with no problems printing anything. Thank you again for your time on this.

One mention of TCanvasD2D Error TCanvasD2D did not mention a solution. Just guessing wildly, have You recently changed Display settings, maybe?

I haven’t made any changes to the display settings.

Are you using print or save after generating the report?

I am using Print, then either selecting a printer or a pdf and neither works. Here is a screenshot of what I get.
Screenshot 2024-06-07 115910

I’ve seen this when printing to OneNote and wanted to rule that out. There is an issue communicating with the printer selected. Instead use the Save option and then print the PDF.

I’ll do that. Thank you!

You may want to re-install your printer

It printed the pdf. I reinstalled it anyway and it didn’t work.

Printers have minds of their own. Had a person in the office who couldn’t print to printer near her, all looked fine with printer. Took me awhile but I figured out she was printing to her “old” printer on different floor! She had changed printer settings so it looked like one by her desk LOL