New RootsMagic Update (8.0.4)

We have released a new update (8.0.4). You can update from the Home page in RootsMagic.

  • New: Added Alt+XXXX support for entering diacritics in Windows
  • New: Added character map (Ctrl+T or right click menu) for edit fields and notes
  • New: Wiki article on entering diacritics (Entering International Characters - RootsMagic Wiki)
  • New: Added color grid to Color Coding for selecting color
  • Fixed: Program now asks for confirmation before overwriting a GEDCOM file
  • Fixed: Source fields don’t strip off leading 0’s anymore
  • Fixed: Entering a diacritic on Mac doesn’t insert an extra character anymore
  • Fixed: Minor fixes
  • Fixed: Cosmetic issues

Thank you thank you thank you for restoring Alt+XXXX support for diacritics!!! :heart: :heart_eyes_cat:

1 Like

It appears the index window now works regarding the incorrect selection of people if you do not do a search before selecting someone. Previously if you just navigated in the list by moving the scroll slider and then clicked on someone, it would select a person about two or three lines below. It appears to work properly now.

1 Like

Nope, they faked me out. The index appeared to be working, but now it’s back the same way, selecting the wrong person.

Also very helpful for entering £ Alt+156, ½ Alt+171 etc. etc. when recording details of English documents and newspaper articles.

I don’t have this problem. However I get to someone in the Index i.e. whether using the search function, by scrolling using the mouse wheel or by scrolling using the slider, selecting the person by clicking on them brings them up in the main panel whatever view I am in. It never selects a person two or three lines below. Same on my desktop or my Surface.

Why was this message posted here and not in News-and-announcements-category?

Terry, I can reproduce the effect every time.

  1. Shutdown RM if you have it running, just to be consistant.
  2. Start up RM and the first thing is to grab the index window slider and pull it down at least half way.
  3. Click on someone in the first part of the window. It should select the wrong person.
  4. If you use the search, it seems to select the right person when you click on someone.
  5. If you use the search, then click the X to clear the search, then drag the slider as before, it also seems to select the the wrong person when you click on someone.
    This may be connected to how many people are in the database or not. I have not tried it with different sizes for the index window. Mine generally stays about half of the column under the current person’s details.

Tried all those and it selected the correct person every time and I did shut down, run a backup and restart beforehand.

What can I say? Mine works differently. I am using Windows 10 Home edition on an EVOO Laptop with 8GB of RAM. The mouse is set to scroll 3 lines, but I doubt that is significant.

Hi, I installed The new upgrade 8.0.4.
It updated fine and said to close RM for the upgrade to take effect. Now my program will not reopen.
I am stuck on what to do. Has anyone else had this problem.

When you do the updates YOU don’t need to close the program - the installation process closes the program for you - it just gives you a warning that this is what it is about to do “RootsMagic will now close…” It then re-opens where you left off with the update done. I am assuming here that you were doing the update from v8.0.1 to v8.0.4 and not installing RM8 which is an upgrade from RM7 to RM8.

You are correct.
I was upgrading from 8.0.1 to 8.0.4 and I thought it said to close the program, which I did.

Now I am unable to open again. Cannot find a backup copy or @nything.

Assume I will have to download RM 8 again, reminstall the Rm program and go from there. Will lose a little bit of input, but can cope with that.

Unless anyone can steer me in a better direction.

Are you on Windows or Mac?
On Mac, the first time you open the program after a new install (including an upgrade in RM8), you have to open the program from the Applications folder in Finder. Thereafter, you can open it the usual way.

Hi Helen
Firstly, thanks for your help.
I am on Mac
I didn’t realize you had to Loper it in applications.

When I try that I get a window which shows Roots Magic icon and the Applications icon below it. (The same way it showed when I first downloaded the program)

When I try to drag the icon into the applications file I get the following error message
“The operation can’t be completed because an unexpected error occurred. (Error code 101000)

Obviously, this is where the problem lies. Unfortunately, I am away on holidays for 8 days from tomorrow morning, so will have to put it on the back burner until then.

Thanks again

Is there a list of these somewhere? Sounds very useful.

I don’t appear to be able to download the update. I am on the Mac version. It starts but at about 80% through the download simply fails, no message, it just stops and the circle for the download progress disappears. I’ve restarted the computer and tried again. But down not work. Internet strength is fine.

Perhaps try a new download from the website and see if that works.

I thought of doing that last night but then had doubts as I read that people had been having trouble after the update with certain aspects of RM8. I began to wonder if it might be a blessing in disguise. lol

Finally sorted the problem. Downloaded the update from
and now updated.

1 Like