Missing Born and Died in Index

A couple days ago I asked for help to relocate Born and Died columns in Index area. Suggestions offered did not resolve issue so I got a ticket for online Tech help but again nothing worked so I gave RM remote access and watched as the technician retried all the moves previously tried and suggested. No result so I have now emailed a copy of the database to RM for further examination.
I am not asking for your suggestions but believe this is not a one-off problem and I and RM would be pleased to hear of them especially if someone found the solution to the missing columns.

I may regret doing so, but I have just now managed to replicate your problem. It’s hard to describe, but I did so by changing the width/locations of the Born and Died columns. You can grab and drag the column boundaries. Doing so seems to act backwards than what you would think. Instead of moving the vertical dividing line I grabbed, it moved the other dividing line in the opposite direction. I kept dragging into the columns were gone. I had to do one drag of a line to get rid of the Born column and another drag of the line to get rid of the died column.

Having replicated your problem, I can’t fix it because the lines I need to grab and drag to fix it are no longer there. I’m not in production in RM8 yet, so I can just probably just delete everything and start over again, but you surely are already in production in RM8.

Added: here is a video on how to recreate the problem. The length of the video is 2:02. How to Lose the Born and Died Columns in the Sidebar Index

1 Like

I know what happened. I will demonstrate it to the tech tomorrow so they can help you fix it. You can either make it happen by expanding the sidebar panel really wide and then adjusted the columns on the right really small, or just collapsing them on top of themselves while at a more normal width. It hard to explain but you need to expand that sidebar panel wider and then move those columns so they are also wider. Then when you collapse the sidebar panel again they won’t collapse on top of themselves.

Decided to make a short video.

1 Like

Renee, I didn’t put it in my video, but when I was testing before I made the video, I made the sidebar as wide as the screen. Having done so, when I recreated the problem there was no recovery possible because the recovery requires making the sidebar wider and I couldn’t make it any wider.

The operation of the width change for the Born and Died columns really should never be allowed to go to the right of the currently visible sidebar. And I don’t understand why the columns move backwards to what the mouse is dragging. That also seems very strange.

Curiously, I couldn’t recreate the problem by making the sidebar more narrow. Doing so simply makes the Born and Died columns more narrow. I could only recreate the problem by dragging the vertical boundary lines for the Born and Died columns.

It’s beginning to look that I’m not going crazy after all. Hope we all get a technical solution asap.

I don’t really see it as something that needs to be fixed. There are people that intentionally want to collapse those columns.

What a cop out answer!

Jerry I was able to recreate the problem no matter what the size of the sidebar was-- and once you lose one-- no amount of pulling on the purple spot will work

what does work is this SOMETIMES!!!

1st where you see the yellow line ( with the 4 dots underneath, try expanding that some more)–sometimes when I do that my died will pop back out…

Next where you see the purple dot, put your mouse on the inside line closest to born and pull to the right on just the inside line ( away from born)-- this usually expands the born–then give the 4 dot ( yellow line ) a quick tug to the right again-- kind of like a little jerking motion–it’s that little jerk that makes my died pop back out…
hope it helps and more to come later

To me, the columns have always moved opposite what they should. This was an issue that I reported along time ago in beta, but of course, we don’t really know what happened to those issues once reported.

…and suppose someone mistakenly collapsed them, or said user wants to restore the columns at a later time? Are they just plain out of luck?

1 Like

I really can’t think of a situation where anybody would want to do that by choice but somebody may be able to enlighten me. In my tree it would just give me loads of John Wells (or whomever) that would no longer be easily identifiable by birth year

1 Like

Just love the idea of getting the dead to pop out by giving them a little jerk. The mind boggles. :slightly_smiling_face:

1 Like

Yep, all the way back to the Community Preview. It’s all columns, not just the Born and Died columns in the sidebar Index. It’s such counter-intuitive behavior that my suspicion is that it can’t be fixed. The behavior is probably coming from a code library provided by the tool that is being used to develop RM8. But that’s just a wild guess about why the columns are backwards. It’s hard to believe the behavior is intentional.

Yes, the direction the columns expand and contract is a limitation we have with the programming tools. We didn’t intentional change it to annoy people.

As for the ability to remove the birth, and now death columns if you check under Options in RM7 sidebar index you will find the option to remove the birth column there. That is a feature some use and want.

1 Like

First, I would truly love to know what “tools” seem to cause so many problems with normal development practices. I can think of no normal programming tools, in a modern language development environment, that screw things up this badly. Most of the environments that I have familarity with are Python, Java and C# tools from place like Microsoft and Jetbrains. If these ooops can be done, I don’t know how to make them happen and I suspect if they can be done, it would be way more work to screw things up than it is to do them the right way.

Yes, some people do want the column gone during use. this should NOT happen accidentally, and if it does, then it should be able to be fixed easily. For example, the RM7 options that you so unhelpfully mention. Put those options in RM8. Let people turn them on or off as they want/need to.

This setting is apparently file dependent as I have now broken one of my test files, yet when opening another file, the columns are as they should be. So where are the file specific settings store? The clearly are not in the XML file where the program settings are.

If the setting is file dependent, then I think they are likely stored in the database in a record in ConfigTable.

I assumed as much, but I was curious to see if Renee answered. Last time I was poking around in the ConfigTable, it appeared to store data in a blob, which was a bunch of hex number in the query results, and I never bother to dig any further beyond that.

Well @rzamor1 , it’s just great you can change the settings in RM7 BUT this is RM8 --there doesn’t seem to be an option to do that-- you can do it for the People List in RM8 picking from a multitude of facts–so is having an option bar for the side bar something that can be added to the feature request list please? As I suspect that if we had that option now and could reset it, the problem would be solved.

I get that some people MIGHT want to hide this ( BUT heaven knows why) and now that I know how to move the columns, I have no problem with that issue except that if you do hide it, it should be easily restored and it’s NOT happening–like Jerry, I expanded my sidebar all the ways and pulled and pulled-- didn’t work-- the only time it came back was when I did a quick jerk–and when I say jerk-- I mean moving the side bar abt the distance between these 2 letters p p–any thing else doesn’t work

Yes, it’s a BLOB of XML. When DataRec for record 1 is copied out as text to a XML viewer, you can see a great number of settings. The two of probable relevance are SideListBirthWidth and SideListDeathWidth, for which 40 is the default value (or the unmodified value) on my system. Maybe it varies with the resolution of the connected display.

To give a little more info on this problem, last month ( Jan 6, 2023) while still under update 8.2.7, I followed Jerry’s suggestion of making a test database to work on shared facts–well last night , I noticed that my test database had no DIED column–so I was thinking, I hadn’t entered deaths but yes I did…

so I deleted all the shared facts and still no DIED column-- I also made a gedcom and sent it to RM 7–no DIED column in RM 7 either…

I also checked a lot of my new databases that I imported from old gedcoms abt the same time ( these gedcoms were made on other genealogy programs) and all of them have a DIED column…

So basically my DIED column was never there when I made the database before the last upgrade–so yes some kind of programing error BECAUSE I never tried moving the columns in my TEST database