Media source corrupt in RM8 after creating from a PAF file

When I create an RM8 file from a PAF5 file the media files are not found. This is because the file name is incorrectly transferred.
c:\Personnel Files\folderjoeblogs.jpg A back slash is missing. It should be:
c:\Personnel Files\folder\joeblogs.jpg. When edited this works ok.

All RM8 media file names are corrupt.

I created an RM8 file from an RM7 file and the file names are correctly transferred. This seems to be a PAF5 problem. The software probably needs a patch.

Not sure how this happened but it should be a fairly easy fix.

  • Make a complete backup.
  • Open the Search and Replace dialog.
  • Choose Multimedia filenames in the Field to Search options
  • Replace all “c:\Personnel Files\folder” with “c:\Personnel Files\folder\”

I was also going to suggest this but if the path error contains the filename (folderjoeblogs.jpg ) and presumably there are other media files folderfredblogs.jpg, folderdaveblogs.jpg etc. then I am not sure that this will work. Worth a try though

Thanks for your advice. Search and Replace dialog not available in free version. Work-arounds not good enough it needs fixing by RootsMagic.

I have now downloaded the latest update (8.1.3) and the problem persists. I cannot change “c:\Personnel Files\folder” with “c:\Personnel Files\folder\”. I have a number of family trees files so \folder\ is a variable. My source is “c:\Personnel". I am not sure PAF problems are considered a priority so I will be patient. I will get the full version once the App works properly. Thanks for your input.

You could revise the path names using SQLite.

PAF died many years ago so do not expect any current software to fix ancient history problems.

Why not simply use the fix broken medialinks command? It works great on mac if all the media folders are within one higher folder.

If PAF is so ancient why do they have the software to transfer from PAF to RootsMagic. If that is the view of RM they should remove it.

I cannot use fix broken media links as it is only available on the full version and when I know it works for me I will upgrade.

I have just updated to and the problems persists.

I have just downloaded the latest RM8 8.1.6 and the PAF to RM8 import still fails to transfer the media links correctly. I do not want to move on until I can use RM8 successfully with my many PAF files. Some have a lot of media files attached so manually correcting the links is not really an option. Help!

If you have not pursued this directly with RootsMagic support, by now, it would seem you’re waiting passively, to your own detriment.

I do not have support as I am using the free version. I do not want to invest in RM until I can be sure that it works with my many large PAF files. So detrimental or not, passively is my only option.

I have just downloaded and the media links still not working. Am I the only user who uses PAF files???

I’m not an expert on media but as no one else seems to be trying to help, so could you please explain exactly what you mean by the media links are not working. Is the format of the links incorrect or do they not point to the correct location? Or have they been dropped in the conversion?

Have you tried the options to fix broken media links? And maybe rebuilding thumbnails?

(I may be talking rubbish here as I am wandering into an area where I have little to no experience, but something might just emerge from the above or from comments from others who know more about this area.)

What do the file paths look like when You instead use GEDCOM to bring your PAF5 data into RM8? Does that trailing slash get picked up?

Probably. I believe PAF was discontinued in 2013 and most people have moved on.

Yet another update ( and still no resolution to the resolution for the incorrect PAF media links.

Unlikely ever to happen. I don’t think they will be using valuable programmers’ time resolving PAF problems - well I sincerely hope not anyway.

You are probably right Terry, but I do hope the RootsMagic team is a bit more understanding and a bit more sympathetic about my problem than you.

Apologies if I sounded unsympathetic, however when you look at the items covered in the recent 8.1.8. update it seems that the RootsMagic team that you refer to is only interested in sorting out issues with Ancestry and Family Search. The whole program now seems to be veering towards “internet genealogy” with the program geared to downloading large chunks of data from the web. Serious research and the reporting thereof seems to have taken a backseat. I am hanging on here in the somewhat forlorn hope that all the features of RM7 will eventually find their way into RM8. Others aren’t and are leaving for Family Historian.