Media Linking issue

In an effort to have all my media files in one place, I did the following:
I put all my media files into a file with the following Path:

When I open the Media tab in the left hand menu it shows images but many have the following icon instead of the image:
Blue colored Square with mountains
Yellow square with flowers
PDF insignia
Blank white page

Other images are correct.

I have tried several times to “Fix Broken Links” but it does not recover the images and eliminate the icons?

I’m assuming RM8.

First question is: what happens when you try to view such images from RM? In particular, what happens if you click on the View (looking glass) icon in the upper right hand corner of the Media screen vs. what happens if you click on the Edit (pencil or crayon) icon in the upper right hand corner of the Media screen?

Those sound like the generic thumbnail icons for the various types of image files such as .BMP .PNG .TIF .JPEG etc. that their default assigned Windows apps (for action OPEN WITH) use. Isn’t that what occurs when media are loaded into RM as type FILE instead of type IMAGE where whatever icon is used by the app assigned as default to open (external to RM) ? Just a guess.

3rd response, all in the same vein… when you select one of these media items, what does the Media type field say (highlighted in yellow)? Thumbnails are generated only for “image” types.

The wiki page Adding Media Items shows

  • Media type - the type of media (Image, Audio clip, Video clip, or Document).

but the program offers

  • Media type - the type of media (Image, File, Sound, Video).

The same discrepancy is on the page Editing Media Items

If I click on the Looking glass I get “couldn’t load image. Make sure this is a supported image type”
If I click on pencil nothing happens.

For the totally blank images in the Media file and I click on the looking glass I get the image. Same if I click on pencil.
Path is: C:\Users\Mike\Documents\Roots Magic Genealogy\media\Wyatts.jpg
But the image on media screen where all other images reside is a blank page.

Kevin and all,
I think you are correct and I need to look into this angle further. I note on some that for some reason the file is duplicated in the filename page. i.e. C:\Users\Mike\Documents\Roots Magic Genealogy\media\CHARLO_3.jpg (2).jpg
I am not sure why there is a duplicate jpg?

That’s a Windows file system convention to handle duplicate files → What Are Duplicate Files, and Why Should You Remove Them on Windows? (

I wonder if these blank ones are image files correctly attached as “Image” type for which the thumbnail image has yet to be generated. In the same 3-dot drop-down menu that has “Fix broken media links” is the command “Build thumbnails” which should generate the thumbnail image for those “image” items that lack a thumbnail.

Be careful about deleting duplicate files downloaded into your media folder because you can lose the RM tag linked to an object (person, citation, etc). I have found that RM links associated with duplicate media may have different tags to people, citations, and places than the original downloaded media file. So for instance, a file myimage.jpg may have a tag linked to one object and myimage(1).jpg (the same image content) may have a tag linked to another object. Before deleting the duplicate media file, I change the RM tag link (In RM) to link to the original media file and then delete the duplicate file. That is a burdensome process but it works for me. I think someone may have a SQLite routine that does a batch operation but I have not tried it.

Wiki has been fixed.

1 Like

I have had a media link problem since just after the testing days. See It is not exactly your problem, but it is a corruption of the media file address, missing back slash (). Never resolved.