"Include in Scrapbook" and "Primary Photo" check boxes missing - RM9

Does anyone know why some media do not have check boxes for “Include in Scrapbook” and “Primary Photo”? I am seeing this in the Edit Person window, then clicking the new Media button.

Bruce’s video shows an example of this at 9:19: The New Media Album in RootsMagic 9 - YouTube

I’m not sure of all the reasons, but I know of one possible cause.

For reasons that don’t matter to this discussion, I enter nearly all my media files into RM7 as type File rather than as type Image, even if they are JPG files. Media files of type File are not eligible for the Include in Scrapbook check box or for the Primary Photo check box.

The reasons for entering all my media files into RM7 as type File do not exist in RM8 or RM9. Essentially, RM8 and RM9 handle media files better than RM7 in some respects. Therefore I am converting all my JPG files in RM8 or RM9 to type Image. Before I convert a JPG file in to type Image in RM8 or RM9, the Include in Scrapbook check box and the Primary Photo check boxes do not appear. After I convert the file from type File to type Image, the check boxes do appear. So is it possible that your media file has been entered into RM as type File rather than type Image?


So is it possible that your media file has been entered into RM as type File rather than type Image?

In RM7, I don’t know how to figure that out. I had just imported from RM7 today into RM9.

In RM9, the jpgs are set to “Image” media type. When I changed to “File” media type, the 2 check boxes still do not appear. I’m seeing this in the new Media button screen.

When I select a jpg, click the tag (under “Other”) then click the Edit pencil, it takes me to the place where I had attached that media. In that place, “Include in Scrapbook” and “Primary Photo” is visible.

In that case, it also was type Image in RM7. So that’s not the problem. I don’t have another idea at the present.

I don’t have any issues in either RM8 or RM9. I can attach an file type and I have the boxes for scrapbook and primary photo. I’m running Windows 11

All my media was carried over from RM7. I haven’t tried adding new media in RM9.

Bruce must know why the two boxes do not appear since in his own video, he also does not have the two check boxes.

I suspect you haven’t gone to the Edit Media page, where both check boxes are shown. Once you have added the media in the Edit Person window, just click on that item to get to the Edit Media section.

Under the Media tab in the left panel, everything in there (all jpegs) have no check mark boxes.

From the People tab in the left panel, double click someone with media.
Click “Media” (which is under “Info”)
Only 1 jpeg (a portrait) has two check-mark boxes. The other jpegs do not have check-mark boxes.

Click “Info” and find the Fact where the media was added. Click Media icon.
The jpeg has the 2 check boxes and both boxes are check-marked.

When I started to generate a Scrapbook (under Publish), there was a very long wait. There is no way to cancel the report other than to close the window. RM9 froze and I had to use Task Manager to close it. Tried again to generate a Scrapbook, this time without printing private facts, and it went much faster. However, the Scrapbook report shows just one photo - the portrait - even though the other pictures were checked marked in separate facts.

It has been that way in Rm7, 8, and 9. All three have had the Primary Photo and Scrapbook tags in the media details and not in in the Media Gallery.