How do I access the character map (what used to be CTRL+ T ) in RM8

I am in the USA and so need to add the £ using the special character map as it isn’t on my keyboard. The character map option isn’t working in the notes field in RM8 - should I be using another option and if so what?


I have a similar problem with adding diacritics. In RM7, I used my numeric keypad to enter them using ASCII ALT codes (e.g., ALT-0241 for ñ, ALT-0225 for á, etc.). That does not work in RM8. RM8’s character map appears to be available only when editing notes.

I’m using cut-and-paste from the Windows Character Map, but it’s a very clumsy workaround – and my database is full of Hispanic names with lots and lots of diacritics. I’ve filed a bug report on this, but I imagine that Tech Support is being flooded right now. Hope this is fixed reasonably soon!


I mentioned this in my brief tenure as a beta tester. I have an extensive line of French Canadian family, and use the é, è, â, and ç marks; it was not acted upon.

This is a definite need.


There is a built-in character map you access via the menu in Notes…still not as convenient as the Alt key combos but faster than cut and paste from the Windows CM…

Second item from the bottom:


fhtess65, having the character map in the notes field is great but as Soprano91396 pointed out it doesn’t work in other fields - making adding names with diacritics tedious.


You’re right - and I feel your pain as I have Polish ancestors with diacritics in their names.


I also requested ASCII ALT codes several times. I believe the answer was that they’re not going to add that option because of how Macs work, but I could be wrong in my recollection.

At the test forum, the answer from the administrators was to “try the Microsoft Office-style shortcuts using the Ctrl key.”

They then linked to this page: Keyboard shortcuts to add language accent marks in Word

I am opposed to using the Ctrl key when I am used using to Alt key shortcuts for many years.

Using the Ctrl method, you’d have to push 4 keys at once to get German umlaut letters (ä, ë, ö, ü, Ä, Ë, Ö, Ü): CTRL+SHIFT+: (COLON), the letter

The Ctrl method doesn’t even work in RM8. I’d much prefer they bring back the Alt method.

1 Like

I realize this won’t help any Windows users, but I just wanted to mention that the Alt (Option) shortcuts for Mac still work for me in RM8.
For instance, the British pound symbol is alt-3 (£).

In MS Office on Windows, it’s actually only 3 characters at once, release them, then the one character to be accented: i.e., CTRL+SHIFT+: [release those keys, then] a, or o, or e, etc. Some international characters don’t require the SHIFT key.

Overjoyed to report that CTL method works for me in RM8 – but oddly enough, it doesn’t work here. If I try CTL+SHIFT+~ and n, I get n, while ALT0241 gives me ñ. It’s better than cutting and pasting from the Windows character map, but I agree with @mapleleaf – bring back the ALT key shortcuts, please!

Alas, it doesn’t work with Polish diacritics :slightly_frowning_face:

1 Like

Regarding CTRL+SHIFT+: [release those keys, then] a, o, u
In Notes it did not work
In a name field, it did work

Ctrl + Shift + column + U brought up the Master Reset window when typing too quickly.

How would one type capital Ä, Ö, Ü using Ctrl + Shift + : ? ?

Bruce needs to bring back the Alt + number method for those of us who want to use that option.

1 Like

I agree it needs to be fixed and reported it throughout the Community Preview period. Hopefully now the major hurdles have been cleared, adding back in features can commence. We’ll see. In Family Historian all I have to do is hold down the key for the letter and it pops up choices. Very slick.

I love many other features of RM8 and believe in not keeping all my eggs in one basket, so use both RM and FH for my tree.


I have alternate Windows keyboards installed for the languages I use that have diacritics not in the standard character set, and that works for entering those characters into name fields etc in RM8. It’s easy to swap between my English and my Māori keyboard by hitting Win-space. (That’s how I typed the ā in Māori without going into the character map). I’ve even tried it successfully with my Japanese keyboard.

To install the other keyboards, type ‘Language settings’ into the Windows search bar, and when the settings page opens, scroll down to Preferred Languages and click ‘Add a Language’. That should then install a keyboard you can swap between in the bottom right status bar (or as above). You might need to Google the shortcut keys for each language pack.

Here’s good instructions for setting up to type in Polish:


Thanks, Suzanne. I did know about this, but when I had tried it on my previous Win10 computer, even if I told Windows to change it back to the English keyboard, it remained stuck on the Polish one (ENG was showing on the task bar)…I couldn’t then use French diacritics. Don’t want the same to happen on this laptop. Fortunately Atlantis Word Processor just added a handy feature for diacritics so I will make up a file with a list of common names and words I can copy/paste until RM’s developers have time to add full unicode support back in again

New RM 8.0.4 update!

  • Added Alt+XXXX support for entering diacritics in Windows
  • Added character map (Ctrl+T or right click menu) for edit fields and notes