Gedcom with direct ancestors ONLY

In the past, I have created gedcom’s with ONLY direct ancestors. Is there a way to do that in RM8 that is simple for us that are not computer wonders?

If helps to understand how to do it in RM8, it’s almost exactly the same as in RM7.

Start with File => Export Data => GEDCOM Then select the folder and the file name. You will be in the GEDCOM Export Options window which is where the action really is.

It may be counterintuitive, but where it says People to Export => Everyone, click on Everyone so you can change it to be something different than Everyone. Then choose the Pick From List option. You will be in the RootsMagic Explorer windows.

Navigate to yourself and check yourself to get started. I find that this particular search box only seems to work for last names, so I have to scroll the rest of the way to myself manually.

Click the Mark button and choose the Ancestors option. There are options about how many generations and whether you also want descendants of those ancestors. Pick a large number for ancestors pick Direct Ancestors Only. Click OK.

Click Select.

Set any GEDCOM export options the way you want them.

Click Ok.

1 Like

Thank you, I’ll give this a try…

What I’m trying to do is make a gedcom of my mother’s ancestors and another of my father’s ancestors. With these, I’ll send them off to get a fan chart made of each so I can take the 2 fan charts to a reunion. This is how I’m trying it.

Create New Rootsmagic File (for viewing my new gedcom)
Empty File
Select file name from drop down list
New file options (surnames uppercase)
Program opens new database (empty)
Back to “Files”
Import Data
Import from RM 1-7 or other program
Select gedcom
Import Gedcom file
Select, NO- Do not add additional source

When I open new database, I have all ancestors even though my mother was highlighted person when gedcom was created.

The problem can’t be related to how you made the new database and imported the GEDCOM. The problem has to be the way the GEDCOM was created in the first place.

It’s hard to know what the problem is without seeing exactly how the GEDCOM was created, but here is a guess. I suspect that your mother might have been highlighted when you began the GEDCOM export process but that she wasn’t highlighted a second time when the ancestors were marked for export. The person who is highlighted when you start the GEDCOM export process doesn’t matter. What matters is who is highlighted when you get into the process of marking ancestors.

So could you maybe describe in some detail the steps that were used to export the GEDCOM?

I understand what you’re saying. I’m really trying hard NOT to have to “select” each and every one of the people manually. There are about 330 total ancestors, of which probably 250 are on my mother’s side.

That’s where you click the Mark button and select the Ancestors option. That get’s all the ancestors all in one fell swoop. You don’t have to do it one person at a time.

Here is a link to a video on making a GEDCOM of direct ancestors without marking each ancestor individually. The video is 2:37 in length.

Making a GEDCOM of Direct Ancestors Only

I watched the video and I can see where I did everything all WRONG! Whilst I was screwing up earlier, I accidentally added duplicates to my existing file… Now I am in the process of deleting all those duplicates… but that’s more time consuming than difficult. Thank you VERY VERY much for the information…

I want to thank you again for the GED video… My problem was I wasn’t getting to a RM Explorer screen and thus was not able to check a “MARK” box. I have created 2 gedcom’s with the aid of your video…

Thank You much

Steven Kadera

Go to yourself and color code your ancestors. Export GEDCOM based on the color.

That’s another way to do it, and it has a certain advantage as described below.

When you are selecting people in the Marking dialog as described in my video, any marking that’s based on relationships requires you first to navigate to the person that the relationships are based upon. Usually the person is yourself, but sometimes it could be somebody else.

I have never understood why this navigational step should be necessary. What I mean by that is that the person of interest is already highlighted in the main People tab. So it seems to me that the Marking dialog should begin with the same person highlighted by default. This would only be a default starting place and would not limit the user’s flexibility or choice in any way. And it would certainly make the Marking dialog easier to use.

This same improvement would be valuable in all kinds of contexts, not just in GEDCOM export. In particular, it would be valuable in creating groups. But curiously, the navigational step I’m talking about is not required when color coding. Color coding of ancestors or descendants automatically starts with the person who is currently highlighted in the main People tab.

Therefore, if you first color code your ancestors, there are two advantages for the subsequent Marking process for GEDCOM export or making a group or whatever. The first advantage is that you can see visually whether you have color coded the correct people or not. The second advantage and the one I’m really talking about is that when you select people for GEDCOM output or group membership, all you have to do in the Marking dialog is to select people based on the color code and you don’t first have to navigate to any particular person.

What’s really easier can be very personal. One way might be easier for one user and a different way might be easier for a different user.