FamilySearch ID -- can't unlink person from deleted ID#

Hi, I’m wondering if anyone else has come across this problem, or better yet, a way to fix it?
I have a family in my file where 3 of the siblings had duplicates in FamilySearch. I went into FS on their website and merged the duplicates. But I can’t get RM8 to let me link the person to the new FSID#, or to let go of the old number.

Here, the person is still showing with the old FSID# (993M-QHH), even though I already used the “unlink” option, and the ‘FS Person Tools’ window is no longer showing her as being linked to that number. If I try to link her to the new # (L6R6-3F5), under the ‘Find Matches’ tab, I get a window asking me if I want to merge the two IDs on FS.

I know that these two people are already merged, but I go ahead and click “Review Match” anyway, just to humor RM. This opens FS in my browser window, where it shows me that person 993M-QHH was already deleted, merged into person L6R6-3F5. I go back to RM, and select “I’ve merged the dups on FamilySearch’”.

This should now link my RM person to the new number, but it does not. If I then open the “FS Person Tools” window for Mildred’s daughter, it shows that RM still has her linked to the old number, rather than the correct FSID# on FS.

Not sure if this whole thing is a problem with my computer, a problem with the API between RM8 & FS, or a bug in RM8.

Just musing Helen_CO_USA

but have you tried reindexing (under file> tools?).
(I’ve not experimented to duplicate your issue)

Thank you for the suggestion, Lorna. Yes, I have run the database tools several times. Also restarted my computer after downloading the latest version of RM8 yesterday. Still having the same problem.

I ran into this problem a few days ago, and couldn’t figure out how to fix it within RootsMagic - seems some kind of button or tool is needed somewhere to unlink this now “vanished from FamilySearch Family Tree” person.

In the end, I used DB Browser for SQLite to peek into the inner workings of the database and delete the offending row from the “FamilySearchTable” - look for the row with the offending ID in it and delete that - that’s what worked for me.

Right click on the row number (to the left of the LinkID column) and choose Delete Record.

Then click the button to “Write Changes”.

Roger

1 Like

Thank you, thank you, thank you, Roger! That did the trick.
You are supposed to be able to “unmatch” a person from a FSID# within RM, but there is a bug preventing that from working, apparently.

I assume that while working with the database in DB Browser, you should have RM closed, and vice-versa, so that the database is only open in one program at a time?

Yes - that would be the safest way to do this. Sorry I forgot to mention that initially.

You’re probably OK having it open in the DB Browser for SQLite while working in RootsMagic, since the DB Browser doesn’t change anything until you click the button to “Write Changes” (which I also forgot to mention), but I’d for sure close RootsMagic before making any change with the DB Browser.

I had it happen twice to me - once when I saw the list of other candidates offered after I’d made the first link, then went off to FamilySearch to merge the duplicates there, then came back to find it broken because I’d merged the one I initially linked in RootsMagic so it was gone. The second time RootsMagic crashed and when I reopened it there was the problem with the link to the FamilySearch person. Both times deleting the affected row from the FamilySearchTable fixed it.

Roger

Thought you might have Helen_CO_USA :slight_smile:
I wonder how often re-indexing of such things happens on the FamilySearch end of the API?
And it will, eventually, come right?

I have a similar problem. In my RM8 file are 877 people with malformed FamilySearch IDs – they have the seven characters, but lack the DASH after 4th character. These individuals show as already matched to FS but provide no information on them in that row other than the malformed FamilySearch ID with the the DASH. There is currently no way to UNMATCH such a person. I have reported this to RM Tech Support, but am curious if others have this problem.

My solution would be to have the UNMATCH button available and then I could rematch to the correct person with the correct FamilySearch ID. This could also imply that the person may have been deleted/merged in FS.

Ugh! That is a lot of people to re-match by hand, even if you use DB Browser (mentioned by Kiwi, above) to delete all the bad ID#'s. If you haven’t done much work in RM8 yet, maybe you could delete the file, and re-import from RM7 (or wherever you imported from), and see if your database comes through better this time? (I’m assuming you did not have this issue in your previous program?)

I did import from RM7 so the problem existed there, but I have not visited those persons. FamilySearch changes person’s ID when merges happen, etc. I have never used DB Browser so will try looking at that too. Thank you.