Creating new role with external monitor on Mac creates infinite dialog windows

RM 9.1.3, MacOS 10.15.7

RM running on external monitor as usual. I multi-selected 3 people to add to a Residence fact. Once they were added I clicked on the first name in the “Shared with” list and clicked on Role, “create new role”. The dialog was unresponsive, I couldn’t type in the role name field or click the Cancel or OK buttons, and parts of the UI were flashing. I saw that RM was using 100% CPU. When I moved the dialog I saw another underneath it. Moved that, saw another, and so on. Had to Force Quit RM.

After restarting, I ran Rebuild indexes, Integrity check, and Remove phantom records. Tried again, same problem.

Then I moved RM to the laptop screen, a single dialog came up and was responsive, and RM CPU was fine.

Just to check, I moved RM back to the external monitor and the problem reoccurred.

What happens when you select lesser people (2 and 1) ?

I left out a bit of detail – the 3 people had the fact shared with them just fine. It’s just that they all defaulted to the Witness role. I picked one of them to change the role and tried to add a role. I know in the past I’ve had multiple people sharing the same fact, and was able to change each one’s role.

I just added a new child to this family. I added her to the Residence fact, then opened the list of people it’s shared with, clicked on her name and tried adding a role (running on the external monitor). Same problem.

After restarting, I clicked on her again and changed the role to the one I had created for the others. No problem, presumably because it didn’t have to open the dialog to add a role.

Technically the default is the first role I believe. If the first role is not witness it will be whatever that is.
In my case Daughter is first for Census. So this is a bit have a issue when using mark multiple people with shared facts – you have to change or correct them. Sometimes that might be more work in the long run and easy to missing wrong (undesired) roles.


I agree with all that. But my issue with adding a new role when RM is on the external monitor remains. :slightly_frowning_face:

1 Like

unfortunately I could only test on windows - not sure about Mac – hopefully a mac user can advise and offer suggestions. If windows I would advise to rule-out monitor driver issue

RootsMagic has no capability to act any different on an external monitor versus the inbuilt display. If it works on the native screen, then Apple’s OS becomes the MITM (man in the middle) for purposes of
external or virtual windowing. Do you get any error message(s)? Can you screenshot any of the symptoms?

All I know is that there used to be access violations when doing simple actions, like adding a fact to a person, if RM was on the external monitor, but not when it was on the laptop screen. Those were fixed by a previous release of RM. It may have been related to a library that RM uses. This case seems similar in terms of different behavior on the external monitor.

There are no error messages. There are MANY of the same dialog, one on top of the other. I could drag them to various locations and screenshot that, but I don’t think that provides any new information.

Hi Terry,
I too have a Mac but a laptop and unfortunately I don’t use an external monitor otherwise I would try to emulate your problem.

Are you able to record a video of your screen (using the middle record icons of Mac’s screenshot app, see image below from Take Screenshot & Record Screen for External Monitor on Mac) and send that video through to RM support showing the issue.