Bug in Narrative report - Surname/Suffix

I am running narrative reports for several ancestors, and set the title to be “Narrative - [Person:Surname], [Person:Prefix] [Person:Given] [Person:Suffix]”.

When I run it for my grandfather, John Augustus Rock Jr., it prints what I expect. It says “Narrative - Rock, John Augustus Jr.” No problem.
But when I get to my French-Canadian ancestors, who have numerous suffixes to their names, there are problems.

My great-great-great grandfather François-Firmin Boucher fils’ (given name: François-Firmin, surname: Boucher, prefix: none, suffix: fils (the French equivalent of “Jr.”) has no problem with I tell it to just have a header of {Person[, but when I separate them into subtypes, and I have a prefix that is not a normally expected on (in English), it prints in order of :Suffix :Prefix :Given :Surname.

What SHOULD read “Narrative - Bouche, François-Firmin fils” becomes “Narrative - fis, François-Firmin Boucher”.

I save the reports as Word documents with the intended title, and I can make the change as I save and then go in and adjust hte header, but it is extremely annoying, and if you have French-Canadian ancestry and have any ancestors with “dit” names, you’ll run into this frequently, it is FREQUENTLY extremely annoying.

I have done some checking and experimenting, and it works when one has a suffix that is comonly expected in English, but it crashes and burns in any other circumstance. If one of your relavives has an MBE (or any other British or Commonwealth honor), or perhaps multiple degrees (Ph.D., J.D.), the same issue will crop up.

Can this be addressed.

I can’t really speak to what the RM developers can or should do to fix your problem. But I will share how I handle titles in narrative reports. I simply type them in the way I want them to appear. I don’t use the variables at all such as [Person:Surname]. I’m pretty fluent using RM’s variables, but sometimes it’s very difficult or impossible to get the titles the way I want using the variables. So I just type the titles in the way I want without using variables at all.

The downside is that when I change families, I have to change the titles. One thing I have never done and I have always intended to do was to switch over from using simple narrative reports to using RMs Book feature for such reports with chapters of the book being simple narrative reports. There is nothing stopping a book from having only one chapter. I suspect that by having multiple books I could hardwire the titles into each book as described without then needing change the titles every time I ran a new report.

In this case, I’m using the Narrative (D’Aboville) form with two generations to create a Q&D narrative of a number of ancestors with their children as templates for biographical sketches of each, and saving them as Word files, sorted by surname, given name (I really only have a handful of ancestors for whom I use prefixes), and suffix. This bug messes with that system.

I also discovered during study that when a suffix does not fall within parameters (Jr., Sr., Ph.D., a Roman numeral, a medical designation), the program treats the suffix as if it were the surname and combines the given name and surname together as one. I would get this even if I did not include the suffix in the title language. It has the same problem even when I simply do [Person:Reverse]; still gets it wrong.

I like the template language, and I’m pretty adept with it, and use it frequently, both to rewrite fact sentences, sources, and headers. This bug is on all Narrative reports, no matter which one ancestors or descendants. It seems to kick in when the suffix does not conform to a narrow set of parameters; it IMO not need to limit to an available list.

Just a followup on this. It was first mentioned in September.

This was not an issue with RMG 7, but appeared with 8 and 9. When I print a Narrative report and display the name with the option :Reverse, it normally prints names Surname, First Name, Prefix (if any), but when my suffix is not on RMG’s limited list of recognized suffixes (Jr., Sr., M.D., Ph.D., MBE), it prints the suffix first, then given names, then surname.

I have a large French Canadian genealogy, and many French Canadians used dit names after their original surnames, and the report gets them all wrong when using the :Reverse option. I took an ancestor, ran a report with him, then gave him the suffix of “X” and ran it again. I’m attaching proof of this.

screenshot 2 header John Augustus Rock
screenshot 3, individual page, John Augustus Rock X

As I said, this worked in RMG7; it should not be hard to get RM9 up to snuff here.

Confirming issue has been reported to development.