Ancestry 2 factor authentication breaks Tree Share

I just chose to use the new Ancestry Two Factor authentication and, understandably, broke RM9 Tree Share. I imagine that this new Ancestry feature came as a surprise to the Rootsmagic dev team. I am wondering if there is a plan to support this?

Best wishes


according to the Facebook group it already does - append the code to your entered password, no spaces.
I’ve not tried this myself.

1 Like

I just did it, and it worked.

I have tried all sorts of different methods and cannot log in with tree share if I have 2F enabled, Turn it off and logs straight in as “normal”
I have seen the comments about tagging the 6 digit code to the password HOWEVER, How do you get one?
I turned 2F back on using my browser.
Went to RootsMagic 9 and entered my login details and got the invalid message. I was then expecting the 6 digit code to come through to my mobile like it does using a browser but nothing ever comes through

My understanding is that you have to use your browser to get the 6 digit code-- then add that code to the end of your password --no spaces to sign into Ancestry on tree share BUT just in case I misunderstood, here is info on how to get the code etc

  • Step 1 is to make sure 2-factor auth is configured properly on Ancestry. In Ancestry, set up “two-step verification” under Account Settings. Ancestry provides the option to have the 6-digit auth code sent to your email or your mobile phone. Test your ancestry configuration by logging in to ancestry via a browser session. You should receive the auth code and be able to log in.

  • Step 2 - Log out of this ancestry browser session.

  • Step 3 - Launch rootsmagic and try to treeshare. The ancestry login should fail, however it should cause a new 6-digit auth code to be sent to you via the same method as in step 1

  • Step 4 - Copy the new auth code and paste it onto the end of your existing password in the treeshare login panel. This login should work and the treeshare comparison screen should launch as usual.

Going forward you can omit steps 1 and 2.

1 Like

Thank You Kevin and nkess, I think the problem would be I didnt log out of my browser. I will have to try tommorow as at the moment Ancesry isnt letting me enable 2F - possibly they are doing maintenance

Thank you for your responses as a result of which I can now log into ancestry via RootsMagic, it was the missing step of logging out of my browser before trying to log in via rootsmagic.

1 Like

Appending the verification code does work. TY

Putting the code at the end of the password worked for me

Update 9.1.0 now streamlines the Ancestry login, especially with 2 factor authentication.