Alert Sounds and Index List

I’m enjoying the RM8 upgrade so far, awesome job. There are two things I cannot figure out how to change. I use my arrow keys a lot to navigate through the tree so I do not have to keep clicking the arrow to move through generations. It never made a sound before, but now as I arrow through people it makes an alert sound. Is there a way or preference to turn that off? The second affects the index list for the bottom left of the main screen. In RM7, I would simply type a letter to go to the top of the letter group. A would take me to the top of the database and if I wanted to start with people starting with E it would take me there without having to use a search. I tried using the search bar with just entering Z and it shows me last names with Z in it not starting the list alphabetically with Z. Is there a preference for that as well?

I haven’t heard sounds using Windows 10.

Your second question is a new search engine feature that was added. There is no setting to turn that off.

Thanks for responding, I am on a Mac and never heard sounds on RM7 which is why this is a little annoying.

I think the new search box is mostly great, but it needs some more options. For example, if I search for my surname of Bryan I’m likely first to see a person named Bryan Anderson. So the search needs some settable options like “starts with” etc. and the options need to be visible right on the search box itself, not deeply embedded behind some THREE DOTS menu.


The clicking must be a Mac thing, Carolyn. I get it too, if I hold down the arrow key, or press it repeatedly too fast. Again, I did not notice this in RM7 for Mac. I don’t know the solution, other than the mute button. Sorry.

The sound seems to be because the input is too fast for RM to process - there doesn’t seem to be a type-ahead buffer, just a single character/key buffer. I see also this on a Mac, so maybe it is Mac specific. As you say, this wasn’t a problem with RM7 on a Mac.

Exactly. Wonder if that is something that could be fixed?