RM9 create gedcom hangs after family count

I hope I am posting in the correct place.
Just purchased RM9 after being away from RM since RM7. I have a fast PC running many complex programs and many other Tree programes. Never a problem. I have cleared and reinstalled 8 times always with the same result.
Progress counts all 45,652 people but stops on family count and will not go any further.
I have to use CTL ALT Del to close as nothing further works.
Task manager never shows any further cpu usage.
Have tried both 32 and 64 bit version. (Windows 11)
I hope this not a case of a re run of my RM7 issues (which were never solved) always being told to reinstall windows as the only option. (Never solved even after a clean install)
The gedcom process is taking 40+ mins to get to that point without media links set! (FTM 2019 takes les than 3 mins with 50,000+ media links)
Any suggestions welcom.

Does the database pass the File.Database Tools.Integrity Test?

My suspicion is that your data has an issue, not a corruption but an entry error, that trips up lineage operations, such as a person who is their own ancestor. RM has no trap for that sort.

Trying to find such an error is tricky and laborious. Possibly facilitated by selected deletion or transfer of one tree or group at a time to narrow down where it is happening.

Thank you for taking the trouble to reply Tom. Database Integrity checks out fine. (I have run all database tools multiple times and no errors flagged.)

That confirms (for me) that it has a data entry issue such as an ancestral loop. You probably cannot do a drag’n’drop of everyone to a new database, either, because that is a GEDCOM export-import in the background so it will fail at the same place.

Make a copy of your database to parse into branches for export and export one branch at a time to narrow down what branch has the problem. Split the problem branch one generation further along and keep advancing along the problem branch until it clears. That might give you a clue where to look closely at your data.

1 Like

Thanks for the reply. A daunting task given the amount of people in file. I have tried old geds from over a year ago all seem to have the same problem. I guess it is a compatibility issue with FTM ged. (All geds and FTM 2019 backups produce a good export when tested in FTM)

@JoeJones @TomH is the expert here BUT I have moved many databases by gedcom from FTM and had no problems EXCEPT for one time-- it didn’t work and appeared to be a good gedcom when opened in FTM-- so I created a 2nd gedcom and that one loaded just fine…
Have you tried uploading the gedcom to a free account on Ancestry ( or using another program such as Legacy’s free tree) then downloading a gedcom from Ancestry ( or making a new gedcom in Legacy)? you don’t have to leave the tree on Ancestry–worth a try AS I used one genealogy program for a while that I had to do this but not in connection with RM

nkness — My goodness age must be catching up with me. After trying everything under the sun and wasting many hours of my life the solution was so simple. Thank you for your suggestion - worked first time and repeated twice without issue. Life saved, thank you once again for your time.

1 Like

Note to self - try the simple basic things first!

1 Like