MyRootsMagic Online Trees

When I try to access any of MyRootsMagic online trees I get:

The page you were looking for doesn’t exist.
You may have mistyped the address or the page may have moved.

Any ideas?

This discussion happened a few months ago. not sure if it’s relevant to your issue - Website url display issue - #2 by kbens0n

Unfortunately, that didn’t help. I got that message when I clicked on the gear icon in RM9 and directly when I used the URL for my RootsMagic website I had previously booked marked in my browser.

Would you post the URL for us to check?

No ‘s’ at the end of http
North Carolina Furrs (

I don’t understand about the No ‘s’ at the end of http.

While the name of the file in RM9 is North Carolina Furrs.rmtree, the name of the website on the MyRootsMagic online tree screen in NCFURR. That is the name I originally used to upload this database in RM7 thus the URL

Does this mean I will have to delete the NCFURR website and set up a new one in RM9?

no. You just have to use one of these links to go directly to your website:

The link CANNOT have https:// at the beginning. It must be http:// or no http at all. https:// uses encryption for secure communication and is NOT SUPPORTED at MyRootsMagic Online Trees.

The Main Page - RootsMagic Wiki is the same way (no https://). I presume this is because they are subdomains of that can be set up, configured and served less expensively or less complicatedly. The retail website and this forum are more protected by the secure communications protocol using encryption.

1 Like

That does not support https results in updated browsers becoming increasingly protective of the user from opening its sites. Iirc, hasn’t Google announced that Chrome will stop supporting URLs beginning with “http:” entirely in the near future?


I don’t use Chrome but I seem to remember hearing that it might issue a “nag” warning for such sites. Yes they are soon going to a new browser extension scheme that is even more secure and unfriendly to adblockers and ad injection schemes.

This page nicely describes the difference between http and https:

1 Like

don’t know abt the near future BUT they apparently don’t support it now without jumping thru a lot of hoops–abt a year ago the W VA Dept of Arts, Culture and History set up a new site and suddenly nobody could access the birth/death and marriage images on the site even going thru Ancestry-- which was a real bummer as some of the birth records went back to before 1850 to 1920, death records images are available to at least 1967 and marriage has a similar range as birth-- well after a few months, we were able to access the images again until just recently because of http being used-- I have 4 different browsers and none worked–when I contacted them, they sent me this very long email telling you how to setup the different browsers ( or download another one) to access the images–the only one that finally worked for me was Microsoft Edge-- if anybody is interested, I can send them a copy of the email that you would have to adjust to get a different site to work

1 Like

I use Chrome as my primary browser, and it already complains a great deal if I try to link to an http site rather than to an https site.

My personal Web site (unrelated to RM) is still an http site. I think this discussion has inspired me to contact the company that hosts my Web site to see what is required to make my site into an https site rather than an http site. Maybe I need a different company to host my Web site.

1 Like

On another note, it was fun to look at the names in your NC tree and see so many of the same names in mine :slight_smile:

1 Like

Check out my Furr website at The Furr Surname

1 Like

Don’t take this the wrong way but my eyes felt bad when viewing your page. I call it a 90’s webpage. It seems like in the 1990’s every genealogical website was laid out in a table with thick borders (see Wapello County, IAGenWeb for an example), or it was center justified all the way from top to bottom. Ok, so CSS was still in its infancy at the time but…

1 Like

It was indeed an early 90s website and I have just continued to add to it over the years:-)

The only work around I have found for that site is Duck Duck Go on my phone.

1 Like has been down for over a day… I wonder if there is work going on re HTTP vs HTTPS.