Merge citations

I have two questions:

  1. I don’t attach images to citations. Is it safe to do the citation merge process?
  2. I have a large database (around 35,000) and when I run the merge citations routine it seems to get to about 40,000 merges and then shuts down. I mean the process shuts, not that the whole program shuts down. What am I doing wrong? Is there a way to break it into smaller chunks?


  1. Probably, especially if there are also no WebTags at citation level. If your citation text is specific enough to guide someone else to the evidence, and/or has the transcription, then the number of merges will be relatively few compared to the merges of citations that are more general. But neither is a bad thing without images or WebTags. The merger of Citations with general text but with specific images or WebTags is still an irreversibly bad thing.
  1. I doubt you are doing anything wrong. Did you run the database tools before merging? It’s not mandatory but maybe worth a try. More likely it is the program’s fault. If you use Windows, open Task Manager and monitor memory consumption by RM before and during the merging. Does it steadily grow? What’s it at when the merge process halts short of completion?

Thanks Tom. I just wanted the community opinion before I tried it.

Hi Tom,
I just tried your suggestions.
I did the tools and I monitored the CPU usage and Memory. It stayed pretty constant throughout.
I didn’t do anything else other than monitor the progress.
I got to 69,620 citations merged and the program is now frozen.

Any ideas?

Does the Task Manager/Resource Monitor show continued significant CPU activity for RM?
How much memory is consumed by RM at this stage? Is it near 2GB?

And maybe it’s not frozen; just too busy “Cleaning duplicate citations” to respond to user input or OS interaction. Maybe leave it for a few hours to see if it eventually finishes.

While the counter is still advancing there is CPU activity. Never above 20% . The memory usage is consistently between 180 MB and 200 MB. I didn’t see any unusual spikes and I watched it carefully. It took about 20 minutes to reach the 69,000 citation mark.

I tried it again this morning. I watched it and it behaved as I have reported. The counter stopped at the same place as last night. It has now been sitting there for 2 hours and hasn’t done anything. When I look at the task manager there is 0 CPU usage for RM which seems like it means that it is no longer working in the background.
I guess it doesn’t hurt anything to leave the citations unmerged. It looks messy and maybe makes the file larger than necessary.
I might just fill out a support ticket and see what they say.
Thank you for all of your advice and for your time.
Jane Neuman

I’m curious if you can export a complete GEDCOM or have it stall somewhere. That may indicate one of two things:

  • a bug in the program
  • a problem with your data (e.g., a lineage loop)

I will try it if you want me to.
But I will add that I just upgraded from 7 to 8 this weekend. Everything has been fine in 7 and I verified that the # of people, families, places, and sources were equal after the upgrade. I had added a few new things before I tried the citation merge.
Is this the process?
Make note of number of people
Export a Gedcom
Import Gedcom to a new RM file
Check the number of people in new file.

The proper way to transition a database from RM7 to RM8 is to import the .rmgc file into RM8 or open the same file with RM8 which will invoke the import. Migrating via GEDCOM risks potential losses.

1 Like

I wasn’t clear! I transitioned properly. But I was asking for the process to try exporting a Gedcom now to see if I got a complete file. Sorry for my ambiguity😏

Run the database tools in the RM7 file. Then do the direct import into RM8 again. Go to Addresses and run merge on both the Address and Repositories tabs. Then go to Sources and merge all sources then citations.

Good morning Renee. Thank you for taking the time to reply on a Sunday! I tried your suggestion this morning without success. It stops at #69,260. I can only imagine that there must be something in the data that is causing a glitch.
I did fill out a support request yesterday and sent my file to you. Later today I will try Tom’s suggestion to export a gedcom.

Looks like Diana has your ticket this morning.

Hi again Tom,
I followed this process to see what would happen. Before creating the gedcom, I took note of the number of people and the number of citations. I exported the gedcom and then imported it into a new file.
The number of people imported correctly. However, I lost about 2500 citations out of a total of 175,000. I know there is sometimes data loss with gedcom imports, so I don’t know if this is “normal” or not.
Just for fun, I tried the citation merge again on the imported file. I followed Renee’s advice and did the merge addresses, repositories and sources first. This time the citation merge got stuck on #69,010. Slightly before the previous time, but stuck nonetheless.
I also watched the CPU and memory usage on the task manager as you suggested previously with the same results; moderate usage for both without any spikes and then down to zero on the CPU usage when it gets stuck.
I really appreciate your advice, Tom. I did submit a ticket on Sunday night along with my file.

1 Like

That the export completed was the result that we tested for. If it stalled, suspicion is thrown on the data. Now it seems more centred on the program itself so hope that the repetitive stalling of your database will expose something that the developers can fix.