Merge All Duplicate Citations tool fails to merge all duplicate citations

I’m a little reluctant to post this problem because I can no longer reproduce it, but here goes anyway.

I have been working extensively in RM9 in parallel to working in RM7. I was entering citations for a death certificate into both RM7 and RM9. Everything went fine and was routine in RM7. In RM9, there were 7 citations for the death certificate and I always Memorize and Paste citations with the Paste/Reuse option. But when I was done with the little project to enter the death certificate, I noticed that the citation had become duplicated. One copy had been used 6 times and the other copy had been used 1 time. The copies were identical.

I am fanatical about always using Paste/Reuse for citations rather than Paste/Copy, but despite that I’m always willing to admit the possibility of user error - the user being me. So I decided not to worry too much about and and I simply ran the Merge All Duplicate Citations tool in the full expectation that I would end up with one copy of the citation that had been used 7 times. But nothing happened. I still had two identical copies of the citation, one of which was used 6 times and the other of which had been used 1 time.

I decided to investigate the duplicate citations that wouldn’t merge, using SQLite to do the investigation. Just from the eyeball test looking at the results from SQLite, the citations were duplicate except for one field. The field was a new field in many RM8 and RM9 tables that provides a modification timestamp for that row in the table. If I had done a Paste/Copy by accident, I would expect the otherwise duplicate citations to differ in their modification timestamp. But just be sure my eyeball test in just looking at the otherwise duplicate citations where really duplicate, I even ran an SQLite script to verify that all fields other the modification timestamp truly were identical. They were.

So I ran the Merge Citations tool on my duplicate citations. That worked fine and all was well. Except that I was still worried that a difference in a modification timestamp would prevent otherwise duplicate citations from being merged. So I Memorized the citation again and deliberately did a Paste/Copy. Doing so created a duplicate citation as expected. I used SQLite to verify that the newly created duplicate citations were identical in all fields except for the modification timestamp. Finally, I ran the Merge All Duplicate Citations tool one more time, fully expecting it to fail again. But this time it just worked. I have no explanation for why the tool failed the first time through and that it worked when I tried to recreate the problem. Additional attempts to recreate the same problem in the same manner continue to fail. The Merge All Duplicate Citations tool now seems to just work every time. And by the way, I did run the Merge All Duplicate Citations tool several different times when it was failing. I didn’t give up after just one time.

Other than “pedal misapplication”, maybe a random neutrino particle toggled the copy/reuse flag? Good thing we don’t do our banking with this software.

I thought I was observing similar behaviour until I had a sudden doogh! moment and realised one of the citations had a media attachment while the other did not. :slight_smile:

I will play with that possibility again. My experience is that the Merge All Duplicate Citations tool ignores media attachments when making its Merge or Don’t Merge decisions. That’s a problem for media downloaded by TreeShare for certain strangely indexed Ancestry collections where the only difference between “different” citations is the media file itself. I hope that problem is solved in the newest RM9. The Merge All Duplicate Citations tool really should take attached media files into account. If that problem has been fixed, then it would be a possible explanation for the strange behavior that I saw.

Right this second, my RM still merges otherwise duplicate citations that have different attached media files. So the problem with merging otherwise duplicate citations with different media files is not fixed, or at least not for me. So the attached media files are not the answer to the puzzle of duplicate citations not merging, or at least not for me.

I had not used the merge all tool before version 9 and my “problem” data was loaded from a GEDCOM, so I cannot comment on Treeshare, but it was the only thing I could find in the very few cases I saw.

The other ‘ignored’ difference is WebTag.

Knowing how the Merge All Duplicate Citations ignores the media, I just spent days of work creating unique titles so the merge would retain the media and web tags with the correct citation. A lot of work!
One new feature that would helpful would be a “Merge All Duplicate Citations for this Source”. That would help be reducing the work of merging citations manually instead of using the “Merge Citation” repeatedly.

Where is this merge duplicate citations tool? I don’t find it under ‘tools’. Citations doesn’t show in the command palette search.

Thank you.

It’s under Sources => THREE DOTS

Yes, that would be extremely helpful.

I see it now. Maybe an enhancement could be to have this listed under the tools also.


I have wondered if there would be a way to automate this process. The trouble is that the only thing an automated solution would really have available to work with would be the media file name, and media file names downloaded from Ancestry are meaningless. Nonetheless, putting the media file names somewhere into the Citation Name field would at least have the virtue of preventing the Merge All Duplicate Citations tool from merging citations that differ by media file. And I always forget about web tags when talk about this. But the same automated trick would work for the web tag URL’s: place them into the Citation names.

Citation names with this treatment would look ugly. But the alternative is blank citations names that will merge automatically despite the differences in media files and web tags.

That is how I manually revised unique citation titles by appending the last 4 characters of the media file name to the existing citation tile. If the citation name was blank, I just inserted the last 4 characters of the media file name in the citation name. That kept citations with a media file from merging with other citations without a media file or with a different media file Not the ideal–but it worked.

RM9 still needs to be FIXED to keep citations from being merged when a media file is attached OR to only merge citations with the same media file and web tags.

It really needs to be the latter. 100% of my citations have media files attached. If merges were prevented when a media file is attached, none of my identical citations would merge.