Media transfer from Ancestry

New to Rootsmagic, but watched a couple videos. have RootsMagic 9.

I have a LARGE tree on and downloaded the gedcom and it did transfer. Took a while.

But none of the media transferred. As I type this, I realize why… gedcoms don’t transfer Media,do they?

How can I transfer my 6,000 files to RootsMagic? There has to be a way, right? Not one at a time? For the record, I have a Mac, desktop, newest model, Sonoma OS. thanks for ANY HELP

No, GED files don’t move media. To do that, you need to create a blank database and use TreeShare to move the Ancestry data into it. There are instructional videos as well as the help files for RM.

1 Like

Here’s the RM9 Help article on using Ancestry TreeShare.

1 Like

So I deleted on of the three files I had transferred, to start over. But now… I can’t delete the other two because all of my tools have disappeared. Meaning on the left side, all I have is “Home”, “File”, and “Settings”. And on the “File” page, most of that is gone too, except for Create, Open, Restore, and “to go”. Any ideas on what happened? Thanks again.

You have to File > Open a RootsMagic file before one can delete that particular database with File > Tools > Delete from within the program -or- optionally, delete the databases through Windows File Explorer if they are not opened in RootsMagic.

Got it! Thank you so much!

If you have a large tree, Ancestry TreeShare can be quite slow, and I never tested it with that many media files. I once tried it with a Charlemagne GEDCOM that I have here, with more than 600,000 persons, and it took hours, but it did work.

How large is your tree, person wise?

I only have 93,000.

So looking at the Tree share instructions on rootsweb, for Ancestry, it says to hit the “publish” page. I don’t have any files in rootmagic (deleted them), and so I have no tools other than “home”, “file” and settings".

So I have to create a new file before the publish button will come back under file?

which I did, but under tools, there’s no “publish”

Got it!
Thank you all

When you create a new file, you will see 3 options. One of those is downloading data from an on-line tree, which can be Ancestry or FamilySearch.

Treeshare… So I opened up a new file in Rootsmagic 9, (I have to or I can’t get to the “publish” button) then selected Publish in left menu. Then I clicked Ancestry Tree Share on the right. I got the window saying I had signed in to Ancestry. Then the Treeshare screen giving me the option to upload or download an Ancestry Tree. I chose Download and chose the tree I wanted. Then clicked on Download. 3 icons appear on my desktop… Tree share directions state under Downloading heading, “If you already have a tree on Ancestry, you will also be given the option to download it into a new, blank RootsMagic database.” but I was not given that option. It just started downloading. But 3 icons appear on my desktop. I’m missing a step somewhere… It’s not in my rootsmagic tree, but on my desktop

What are the names of those icons? When I download my tree, named ‘borg’, I get a new RM 9 database named ‘borg.rmtree’ and a media folder named ‘borg_media’. There’s nothing new on my desktop, because I tell RM to save the new database in my Documents folder.

I’m trying that … to my documents folder. It probably is that simple! We’re at 3% importing. Thanks again!

fill in these so that RM can locate the files, etc


Well, the following is what I did, and then I turned it off and on and restarted my computer. Still not working. Let me know if this looks right?

Well, something worked, kind of? I did the “fix broken media links” after restarting my computer, and 1996 broken links were fixed and 64376 not fixed. I’m going to run it again.

Well, zero links fixed the second time around.

that should works looks good

You should look at the media that “Isn’t Fixed” for the path/filename to where it should be. Locate that pic on your computer and make sure they are identical.