Individual Fact's Proof setting is "blank" but acting like "Disproven"

Hello, I have used RM since the beginning and have recently encounter an odd behavior (possible bug?) a few times this morning. I was adding information for individuals in an existing family. After adding an event (like a Marriage), the font was red / strike-thru for the event name, date and location, instead of black and no strike-thru. This usually means the Proof setting for the event is Disproven, but that was not the case. It was set to blank (no setting). If I set the Proof setting to a value, then change it back to blank (no setting), the red font and strike-thru is removed. This behavior was not consistently happening when added an event.

Any suggestions as to what may be causing this?

I haven’t seen that happen. Don’t believe we have any reports on it either.


Do you have a backup that contains it showing the strike-through even though the proof settings is not selected?

Unfortunately, I don’t. I worked around the issue, as outlined in the original post, before I closed the application and backed up the database. Also, I directly queried the underlying SQLite database’s EventTable and all of the Proof field values are either 0 or 1.

If I run into it again, I will post back to this topic.