"FamilySearch Person Tools" page constantly freezes

I’m really starting to regret switching from Legacy 9 to RM8 as I’m finding the FamilySearch Person Tools page constantly freezing up on me. The only solution I’ve found to work is to do a Ctrl+Alt+Del and shut RM8 down completely and restart. A lot of times when I go back into RM8 and try to do it all over again, it will freeze up again! It seems to not like skipping more than 20 names or so down the person list as if the program is buffering memory. For a file that’s 6000 individuals long, this is unacceptable. All I’m trying to do is go to where I left off in reviewing FamilySearch source material versus what’s stored in my RM8 file. Between this issue and the constant Access Violation errors I’m about to throw in the towel and go back to Legacy 9.0. RM8 Support is zero help as they constantly keep referencing CCleaner and Malwarecleaner process cleanup step as if magic dust will fix my problem. I’ve tried it and it doesn’t work. Does anyone have these issues and have you gotten around them?

A pissed off RM8 user,

As someone who spent a lot of time as a software tech support person, it is my opinion that such reference basically means the tech hasn’t a clue what is wrong. Back in the day I worked with a lady who always told her callers to wash the CD if they had an installation problem, even when it was fresh out of the packaging. Of course that was before everyone was able to download the program installer. I suspect the aforementioned tech would tell her callers to unplug their network cable and blow ot the port with compressed air, then try downloading the installer again…

They’ve been doing this for years. I have never seen anybody respond with “That sorted the problem”.

Do you have more than one monitor you are using? Is you database inside a folder syncing with the cloud like OneDrive, GoogleDrive or Dropbox?

Check your security software to see if any of those are blocking RM access to the internet. If you have installed a separate security software package make sure Windows Defender is also not turned on. Malwarebytes no longer works with Windows Defender. It is seen as another antivirus software and will conflict.

Hi Mike. I experienced the the symptoms you described in several earlier versions of RM8 in Windows 10 but have not experienced them lately. It happened when I was repeatedly scrolling the index of names to get to a specific name. Make sure you are on the latest version 8.5. I also have my files on both Dropbox and OneDrive running Malwarebytes Premium and Windows Defender.

1 Like

My computer is a MS Surface Pro 7 connected to an external 34” monitor. The file is located on the C drive but backs up on Dropbox.

Another oddball software behavior is sometimes I get that Access Violation error and I’ll move on down the people list for a moment. A few times I’ve gone back up to the person that caused the violation and it’ll work. Therefore, I almost feel this access violation in my example is the software isn’t able to access the data in the allocated time and flags an error.

Yes, that was the behavior I experienced during rapid scrolling of the person index. The behavior was similar to a buffer overflow error where the scrolling process was interrupted. It also happened to me when scrolling the media list (By file name). Don’t know why but it is no longer happening to me.

That means it’ll take about 20 minutes to scroll down my 6K people list and not freeze up the program. So frustrating!!

If you mean that the .rmtree database file is in a DropBox folder, make sure you pause syncing with Dropbox from before you open the file with RM8 until after you close it. Not saying that’s the cause of this problem but active syncing a RM database risks file collision, contention or corruption.

You’re also using a second monitor so that is known to have some issues.

The backup is on Dropbox. The actual file is on my local C drive.

Do most individuals use a single monitor with a desktop computer or just a laptop screen when using RM8, then?

From posts there is a great deal of variety in computer configurations. I use a Windows 11 Laptop with a second monitor hooked up. I do not have issues, but I use RM on my laptop, monitor 1, and only use monitor 2, for documents or websites I am transcribing or viewing.

I have 55K people and I have never had this problem. I am using Window 10, but I do not connect my file to any external sources (Ancestry, FamilySearch, etc.). My biggest pain is when I seemingly lose the edit page on a person. I thought it was locking up, but it was still there, hiding behind my People page. Clicking the icon at the bottom immediately brought it back. I do have an error pop up about every 3-4 weeks, and then I just backup, close, and restart the program. Funny (not really) I used FTM for years and when they did a major update, it would not open my file. After I sent them my file, they could not open it either. Their only suggestion was to use RootsMagic. No, they did not refund my money. Yes, still a lot of bugs to work out.

1 Like

I am using a laptop and sometimes hook up a second monitor. I don’t have any freeze ups.

1 Like