Family Group Sheet Not Printing in RM9

Downloaded the 64-bit version and attempted to print the Family Group Sheet report. It performed if you only click on one family. Selecting 2 or more families proved too much for the software and nothing happened.
I received the error message as attached.

My goodness that’s a crappy photo but …

Hopefully help will arrive soon!

Attempting to print several families in Family Group Sheet report. On the “include?” setting, if I check off 1 or 2 families, the report generates fine. If I check off more than 2, no report is generated. The generating report message pops up for about 2 seconds and then area where the report would normally show up is grayed out still.

I have no problems printing the report when checking multiple families in RM8.

Sadly, I didn’t realize I would have this problem until after I chose 100 families. To that end, is there a way to save the criteria of the report so that I don’t have to check so many families if I need to run the report again? Using the save function, only saves the report and not the criteria.

Any help is appreciated.


I had the same problem when attempting to add more than two families while printing family group sheets. I reported it, but the technical staff couldn’t reproduce it. So now, when printing multiple family group sheets, I use the Book feature, selecting a different family for each family group sheet in the report. It has the advantage that the Book of family group sheets can be saved, so an updated version can be printed at a later time.

Thanks Robert. I appreciate the help.

I am getting the following popup on my screen now when I try to print.

I was thinking I would do a fresh install of RM9 on another computer that had never had a RootsMagic version and see what happens.

Thanks again

David-- this access violation is from RM8–the error above is from RM 9-- you probably tried to save a report that was just a grey screen --at least that is how it happened to me–reason I tried to save a blank screen was because at the top of the page it said I was on page 4 of 26–update I received the same error just trying to create a report with more than 2 people…

Once you get these errors, you need to exit RM --even if you have to use the Task Manager-- then reopen and try running the database tools before doing anything else…

decided to do a little checking on family group sheets…

RM9-- in my test file with 5 families, the report generates just fine-- my test file has a lot of facts BUT not much in the way of notes-- more than 5 families, just a gray screen…
in any of my regular RM 9 files, the report will NOT generate if I have more than 2 people-- I have a lot of notes etc in my regular files BUT it would NOT generate the report even when I stripped everything but basic facts out…

RM8-- same results in any of my regular files…

RM7— I tried 13 families on one of my regular files and the report generated just fine even with including the notes ( a lot of notes)…

Since I can do 13 families in RM 7 BUT not more than 2 in RM 9, it would appear it is a bug in RM9 @rzamor1

So besides Robert’s suggestion, you could also save a gedcom of RM9 files and open it in RM7 to generate the report-only thing is everybody says there can be data loss in a gedcom–I personally have had no data loss except for associations…

just makes sure to backup your file before doing anything.

Performed the database tools without error and tried to run again. Same error as in OP, “The process…” Clicked OK and exited RM9 just fine.

The 2nd image is from RM8. Before installing RM9, I was able to run multiple Family Group Sheets without error. Since installing RM9, I received the 2nd image. Not sure if it related but something’s up.

I also started RM9 with as Administrator and still have error.

I changed my windows explorer settings to Hide Protected Operating Files and Hide Hidden Files, tried to run the report and instead of a blank screen, it shows Generating Family of … but it stalls there. It does not continue to the next family. Not sure why changing the “View” options in explorer would change things but at least it’s something different. Still not a report but baby steps.


In report settings, make sure sources are outputted as end notes, not footnotes, and see if that helps.

Thank you for all of your assistance. I finally got the report to print as desired. To do this I completely deleted all versions of RootsMagic (8 and 9) and deleted folders that referenced RootsMagic. I then reinstalled RootsMagic 9 files as instructed on the download page.

This issue is now closed.

Thanks again

Did that include deep diving into the AppData folder?

Had you ever tried the RM reset Ctrl+Shift+U?

Yes, included AppData folder. I deleted the programs first with RevoUninstaller, then the deep dive.

Before I did all that I used the Database tools in RootsMagic to make sure something wasn’t glitchy with my data.

Have never used RM reset.

It resets to default settings and wipes some history all stored in a XML file stored in AppData. It’s equivalent to deleting that file and has helped some users. It might have been all you needed.