Error Message when trying to Drag and Drop

I am trying to drag and drop between 2 family trees one of which was downloaded from Ancestry and the other was imported from Family Historian. They are of the same families and I an trying consolidate the information in each of them into one database hopefully with the correct information.

I have successfully dragged and dropped before but now I when I try to copy the same person from one database (the one originating in Family Tree to the Ancestry one) in order to avoid having to retype load of facts in the person sheet I get a message that says " Unexpected Error Cannot perform this operation on a closed statement" It then invites me to send an error report to RM which I have done numerous times. What does the error message mean and how can I get around it or is it a bug?

When I opened RM 8 this morning it invited me to upgrade it so I am now using version 3 Jan 2022.

Is there anyway of exporting person sheets from 1 database and them importing them into another database.

Or is there any other workaround?

Thanks for any assistance



A drag and drop works behind the scenes by doing a GEDCOM export and import. You could do the same thing manually. Namely, export your one person of interest from your database originating in Family Tree to a GEDCOM file. Then import that same GEDCOM file into your database originating in ancestry.

It’s not quite as convenient as drag and drop, but the final result will be identical. For the export in RM8, the sequence is File tab => Export Data => GEDCOM file. The sequence for import is File => Import Data => Import From RootsMagic 1-7, GEDCOM, or Another Program => GEDCOM.

It sounds like a programming error or that your system is in a state that is not anticipated in the code. Try closing RM down, restart it and reopen the databases, run the Rebuild Indexes tool on both and then try your drag’n’drop. If same error on the person of interest, try another person and see if it’s repetitive. If so, seems like those two databases should be submitted to Tech Support along with your description for them to analyse and fix the problem.

Thanks to thejerrybryan and TomH for their responses. I did try the export to and from a Gedcom file. It worked fine except that it created an additional “unassociated” person with none of the relationships that exist in both databases.

I had tried closing down and starting again and also other people with the same result. I tried the rebuild indexes tool again with the same result.

But then, in the nature of these things, later I came back to RM and tried again and it worked. So there must have been a particular set of circumstance that caused the error to happen which went away and so it worked. I will try again later on today and see what happens.

Thanks for your assistance.


One advantage of doing a true GEDCOM export followed by GEDCOM import is that you can look at the GEDCOM file to see which individuals were transferred. On Windows, you can use Notepad or most any text editor for this purpose, and you can use any text editor on a Mac. I can’t quite visualize how you got an unassociated person, but looking at the GEDCOM file should give you a good clue. I wonder if this unassociated person is the root cause for the drag and drop to have failed in the first place.

I do assume that since you are combining files that you will get some duplicate people? If so, you will need to manually merge all your duplicate people after the GEDCOM export/import.

I think Jerry nailed it and especially if you exported just the one person - it will have no relationships and it will be a duplicate of your target person. You will have to merge the import into the target that has the relationships in order to bring over the extra information into the target. And there may be some cleanup to do with duplicate facts or fact types which you can address in the manual merge.