Entering RM Key

I purchased the RootsMagic holiday offer and received an email with my RM8 key.
I went to RootsMagic and downloaded RM8 and then imported my RM7 file. It all worked except I was not able to enter my Key to use all the features like Tasks. When I select the RM icon on my PC desktop I get a screen that asks which version I want to use. I selected the full registered version and entered my name and key to use the Full Version. The ‘Unlock’ button does not work. Any help would be appreciated on how to enter my Key

If you have copied then pasted the key, check to see if you have picked up an extra space at the beginning or end. Or try entering the key manually. It starts with the RM8xx

Just tried to enter it manually and still the Unlock doesn’t work. Thanks for trying

Are you entering the name exactly the same as the way you entered it when you made the RootsMagic 8 purchase?


Roger, I don’t believe names need to match the purchase name as you can gift a program to someone. Although perhaps if you registered the key prior to entering it to the database, it may look for a match. That would be a question for support.

Thanks, I have sent an email to support. I can use my database just not all the things that require the full version.

I seem to remember that in RM7 and earlier versions some people were storing their database in a “protected” file location, and that Windows was preventing the key from being properly saved. Maybe Renee can clarify.

Thanks for your response. I have resolved the problem. I did not have all the digits of the Key! User error.

1 Like