Dating issues are waiting for a solution

Hi for All! :slight_smile:

Just faced with this strange date issue years ago with the RM7. I was waiting for the RM8 with hope it is solved but it is still on with RM9. The whole tree is synched “from” FamilySearch.
[image] (As it is my first post I tried to paste the screenshot but with no luck)

There is also no date of death displayed even it is in a correct format.

Have you run the Database Tools, in particular, Rebuild Indexes which extracts the year of the dates of B, D to populate the fields displayed in the sidebar Index?

Thank you TomH!
There is no option to run any Database Tools by the RM9. I am stucked in the “try before buy period” until some elemental issue is still on.

Command Pallet>Database Tools
Tools>Database Tools
File>Tools>Database Tools

You should run all of them from top to bottom periodically.

The OP says he is stuck using the “try before you buy” version which means the Essentials version. Database tools are not available in the Essentials version.

1 Like

Is your RM7 capable of running its File>Database Tools (i.e., it is the licensed, paid version?) If so, run them and fix the problem there. Then re-upgrade the database to RM9 without the date issue.

Try a drag n drop. That will show you if its an indexing issue or not.

@palos – I know this will sound really dumb BUT occasionally when I am on a family page everything looks right-EXCEPT the marriage date is NOT showing on the FAMILY VIEW PAGE–so I go in and check-- thinking I didn’t enter the marriage fact BUT I did… I delete that fact and reenter the info and it is usually okay!!!

Don’t ever remember seeing a birth date in the family view missing in the index–so I went and checked-- IT’S IN THE FAMILY VIEW FOR ADDY COON but not the index


hope it helps

1 Like

Rebuild Indexes should update the YoB and YoD in the sidebar index and anywhere else the year only is displayed.

In the sidebar it is also showing that Coon is in the given name field and not the surname field. You will want to fix that so they appear correctly in the index.

Thanks Renee-- I do realize that BUT my main concern was with the dating issue and ways to solve it BUT since you mentioned that-- I went back and looked at RM 8 for Addie Coon

have never fixed this in 8 and can’t imagine why RM 8 and RM 9 are different but not worried abt it-- just an FYI

Thanks Tom BUT my main concern was trying to give @palos another way that he MIGHT be able to fix a problem from years ago with RM 7

Since I had already fixed RM9, I created a 2nd file by importing a gedcom

As you will note this time there is NO DATE of birth in the FAMILY VIEW or INDEX BUT the FACT is there— when I first imported this and looked to see WHY-- on birth it said I needed to define sentence which I did and then backup the database and still have the same result EXCEPT the sentence is now defined


Then deleted the fact and re did it and problem solved

1 Like

On the People page 3 dot menu go to Fact Type List and check if you have more than one birth or death fact. Only the default Birth or Death fact will show on the index lists. You can tell if its the default fact types because the Name and Abbreviation fields cannot be edited.

That’s a plausible explanation as to why Rebuild Indexes would not have retrieved the YoB from the ‘Birth’ event - it’s not the built-in Birth type.

No TomH, the RM7/8 are not even the paid version.

Rzamor1, how do you mean it? Of course, I can drag the person from the “Pedigree” (at the right part of the screen) but where to drop it? The plus sign icon turns to a crossed circle icon when I move over the list of names at the “Index” at the left part of the screen. :smiling_face_with_tear:

Yes nkess, you are right, it works! Thank you!
It is nice to see that so many helpful people here at this community!
Cut&save + paste&save solved it. I have less than two thousands of records and this issue is not on the full number. :wink:

I am facing with many more elemental issue. Should I open a topic for each one?
Now I have a solution but I do not think that the issue can be marked as solved at all.

1 Like

Create a new, empty RM file and drop into that. The new file will have all new table indices so this test will confirm whether or not it’s an indexing issue.

If you have any more date issues, you can fix a bunch at once IF they are due to the fact that you have 2 birth facts, death facts etc…
For whatever reason, when I switched from one program to another and finally to RM, somewhere along the line, one or more of the programs did NOT like the birth/ death facts etc-- I also had some customized facts because one program used LIVED instead of LIVING ETC-- well with RM 9, you can bulk change a fact from one to another–

so as @rzamor1 suggested above,

3 dots is on the right side where the +, trashcan, pencil etc is-- click on that–select fact type list and you MIGHT have 2 births as I do

Click out of that and go to tools left side— click on Change fact type for everyone

( note I usually mark the 2nd fact as Birth 2/ Death 2)

Enter change the 2nd Birth to the 1st Birth-- hit run selected tool , then go back and check your people to see if that took care of the problem as once you hit Run, it does not tell you it has been done…

if you fix the duplicate birth/ death/ burial, it should clean up date issues-- ( and delete the 2nd birth fact once you are sure it is not used)…
and defining the sentences for any others that can not be changed to something else will also help

Other than that I guess if you have other problems, try searching upper right hand corner of this page-- and if you don’t see your exact problem, post it…