Conversion of RM Sources to Ancestry Tree Share Source Detail

Are there specific rules as to how RM7 or RM8 source template fields are converted to the source title and citation detail that Ancestry Tree Share creates? Also are there any limitations on the number of characters that will transfer? I have been creating layered citations based on Evidence Explained guidelines for church records from the Finland National Archives and the Finnish Family History Association websites. The document titles are in Finnish and they become very long when including translations to English. I’ve tried different approaches and I am finding that my
special source templates/citations do not transfer very well. It would be nice if there was a set of conversion rules. Is anyone aware of them?

I have only been concerned with field mappings not field size so will need others to comment on that aspect of your question. Also, am restricting my comments to the use case of a non-Ancestry source being added to RM db and then pushed to, which I believe is the crux of your question. (There’s addition considerations affecting the behavior of data that originated as an Ancestry source.)

I’ve included the detailed results of my tests below. Some summary comments:

  • First is that source templates matter. If you want an easy to read Title in Ancestry, the cleanest template is to use the Ancestry Record template. For every other template I have tested, the Footnote gets mapped to the Ancestry Title field. I have not tested with customized templates, which you might want to do.
  • Second is that Fact Notes get mapped into a separate Source Citation listed on under ‘Other Sources’. This is a useful place to put helpful information.
  • You’ll see that the all of the 4 major RM source citation fields get mapped somewhere in Ancestry except Source Comments.
  • Lastly, you’ll see the references to html chars. This was an unannounced Ancestry API change last year. Prior to that, html formatting tags worked. I have not tested since the recent API changes that Ancestry made last month, so the list below is at least 6 months old.

OK, my test is to add the field name as the value for each field and then push a citation to Ancestry.
1. Fact Type
a. RM Date field goes to Ancestry Fact Details “Date” field
b. RM Place Details field goes to Ancestry Fact Details “Location” field
c. RM Place field goes to Ancestry Fact Details “Location” field (Place Details, Place)
d. RM Fact Description field goes to Ancestry Fact Details “Description” field

2. Source fields
a. If using Ancestry Record Template, RM Title field to Ancestry Source Title field. For all other templates Footnote field goes Ancestry Source Title field.
b. RM Source Text (Master Text tab) field goes to Ancestry Note field
c. RM Source Ref Number field goes to Ancestry REFN field
d. Ancestry Author, Publisher, Publisher Location, Call Num, etc all blank
3. Citation fields
a. If RM template has a Page Number field, data goes to Ancestry Citation Detail. (This is probably any RM citation detail field… have not tested with lots of RM templates)
b. RM Detailed Text Research Notes field goes to Ancestry Citation Transcript
i. URls dropped (probably anything “< brackets>” )
ii. Anything inside <> does not show in Ancestry Research notes unless in edit mode. It does get passed by RM
c. RM Detailed Text Comments goes to Ancestry Citation Other information
i. URL kept
ii. Anything inside <> does not show in Ancestry Research notes unless in edit mode. It does get passed by RM

Thanks, kevinm
You are correct, I’m interested in non-Ancestry sources created in RM being pushed to Ancestry. I was getting ready to attempt some testing, but thought I’d ask if anyone knew how the source and citation fields in RM mapped to the same in Ancestry. I am testing out some things now based on your comments. I think my 3 layered Evidence Explained source citations are beyond the scope of how TreeShare was set up. If I come up with a better solution I will post it.

After some additional testing, I am finding that the number of characters in the citation detail being transferred to Ancestry from TreeShare is limited to 256, which my citations have been exceeding. The fields in my custom source template are all transferring properly. That is, all fields as part of the RM master source are transferring to Source Information Title in Ancestry and all fields associated with the RM citation are transferring to the Citation Information Details in Ancestry (up to 256 characters). It seems like a simple fix for this would be for Ancestry to allow more characters in the Citation Information Details. But I believe that is something that would require a change in the API.

To help show what the problem is, here is my source citation as I believe Evidence Explained would suggest:

Level 1 - What the document states
Kuusamo seurakunta [parish] (Kuusamo, Oulu, Finland), Syntyneiden ja kastettujen luettelo [List of births and baptisms], vol. IC: 5, 1837-1855, (also includes marriages and deaths),

Citation Details:
Baptisms, entry for Johan Kallungi, 24 February 1846, unnumbered pages arranged by date;

Level 2 - Where I found the document
imaged in Kansallisarkisto [National Archives of Finland], Digitaaliarkisto [Digital Archives], digital images, (Digitaaliarkisto : downloaded 24 September 2021), path: > Kuusamon seurakunta > Kuusamon seurakunnan arkisto > Syntyneiden ja kastettujen luettelot > Syntyneiden luettelo 1837-1855 (IC:5), image 77 of 215;

Level 3 - Source of the Source
citing Oulun maakunta-arkisto [Oulu Provincial Archive].

I was including all the Level 2 and 3 information in the citation detail fields in RM. There are ways to shorten the information by leaving the website path to the document out, and eliminating the translations and using either all English or Finnish, but my preference is to include all the information.

When performing the testing, I was unable to edit my source and have TreeShare make any changes after the initial upload of my RM Tree. I had to delete the citation and re-enter it to be able to see the change through TreeShare. This is something I will follow up with RM Technical Support.

You might want to test putting your level1,2,3 data into the fact note. Fact Notes create a 2nd source doc in Ancestry with content going to the ‘Other Info’ field which supports >256 chars. Not sure what the limit it. This is not a proper fix but might provide a path forward while waiting for Ancestry to make changes to their API.

I tried a number of things, including what you suggested regarding the Fact Note. It works for the tree on Ancestry, but then the information is left out of the footnote in RM, which is a problem for me. What seemed to be a little better was putting the levels 2 and 3 into the “Citation - Detail Comment” instead of the “Fact Note”. Then all of the source and citation information is in one location under “Other Sources” for the appropriate fact on Ancestry. But still the RM footnote is missing all the level 2 and 3 information.

Here are a few things I found.

  1. The “Citation Information - Detail” in Ancestry is limited to 256 characters, but these other fields like the “Fact Note” and the “Citation Detail Comment” have larger limits. In my test citation there are 406 characters.

  2. When you have several fields as part of the citation, they are added sequentially to the “Citation Information - Other Information” in Ancestry, but with semicolons separating the fields. This violates the recommendation from Evidence Explained (EE), which uses semicolons to separate the levels or layers, and commas to separate information in a citation like page number, line number, etc. It is also in contrast to what happens with the “Source Information - Title”, which separates the individual source fields by commas.

  3. The character “>” which is used to describe the path to the source document on a website does not transfer to any of the locations in Ancestry. Things like fields which are in italics, just send the codes . I suspect the same would be true for bold and underline.

  4. Making a change to the source or citation shows up as a change in the “TreeShare for Ancestry” window in RM, but selecting “Update existing event on Ancestry” then “Accept Changes” does nothing. You have to go to the Ancestry Tree, delete the source, then come back to RM and repeat the process to update. Then it works. I wasted a lot of time figuring that out. How many times do you realize your citation has an incorrect page number. Correcting it should be easier.

I’m new to the RootsMagic Community. Is this the best place to request feature changes or enhancements?

I don’t know how best to suggest a feature enhancement. Probably a clean thread with just the specifics.
re: #3 - my experience is that the hash tags are being passed by RM to Ancestry. If you click on “edit Source” or “edit Citation” in Ancestry, the “< >” chars should be there, they just don’t display in ancestry.
re:#4 - Your comment is accurate, correcting details should be easier. Treeshare has worked this way for as long as I have used it. The amount of work required to manually maintain data integrity was too much for me, so I switched to a strategy of using treeshare as a way to pull info from my private, ‘research’ ancestry tree and I periodically push an entirely new tree up from RM to Ancestry as a separate ancestry tree that I make public. Then I delete my old public tree. Not ideal, but less frustrating.