What happens to RM 8 now that RM 9 is released

There are still a lot of little annoyances in RM 8 like small bugs in the note editing function that still haven’t been fixed to be as usable as RM 7. Is RM 8 now frozen so that these things won’t be fixed?

1 Like

Another example of the small annoyances that are still present in RM 8 that haven’t been fixed. In the search function, if you hit enter it just goes to the next line instead of initiating the search function like hitting enter does on web sites and in other software.

1 Like

Having spent a year getting use to RM8 & working around the many bugs I am surprised that its being replaced after a year & that we are being asked to pay again for a new version which will entail relearning how to do everything again.
I will be very interested in what support will be provided for RM8 in the future & for how long.

Actually RM8 has been at for year and a half now. Many programs do yearly releases. As for learnign how to do everything again, no, because what you are used to now, it is about 99% the same in RM9. RM9 is just RM8 with some new features.

As for support, RM has pretty much alway provided support for their previous releases until people move on to newer ones. If you post here, or on Facebook or somewhere to ask questions, make sure you specify what version you are using. Now as for updates, those usually stop with the release of a new version, so it is not likely that you will see further updates, but questions about RM8 will continue to be answered.

1 Like

Don’t hit enter in the search box. Just enter the text you are searching for and it will display it.

RM8 will continue to have tech support. Only updates have stopped, since the current version is now RM9.

Have all the bugs in RM8 been corrected in RM9? RM8 has been very frustrating. Will my frustrations continue in RM9? I wish I had stayed with RM7. It worked and it worked well.

1 Like

Have all the bugs in RM8 been corrected in RM9> Blockquote

missing features vs bugs? with any new release much less major release there are always old bugs fixed and new bugs. Some things may appear to be bugs from the user perspective but actually functioning as expected (from the developers perspective).

That said – what bugs in 8.5.0 have you found that present?

Most editing key shortcuts are missing and some simply don’t work correctly. Ctrl-C, Ctrl-X, and Ctrl-V seem to be OK but Ctrl-Shift+an arrow key seldom works and/or gives an error message, “You have reached the end of the history list.” Also, when creating a note for an event, if I hit the delete button at the end of a line and then hit the down arrow, the cursor jumps to the very top of the note.

Also, I’ve had problems when entering an event. I enter the date and location, then click on the sources icon and the date and location disappear and I’m left with a source on an empty event.

In terms of features, I wish we still had the Alt-S for sources or Alt-O to close a source, event, note, or whatever. Too many things disappeared with RM8. I realize it was a complete overhaul but these useful “features” should never have been deleted. The end result is that I spend way too much time switching back and forth from the mouse to the keyboard.

Finally, what’s with the “RootsMagic has encountered an error” messages? I’m not sure that’s the exact wording but it happens a lot. I have to then close the program and reopen it.

I’m operating on Windows 10 with dual monitors. (I wish RM would remain on the right monitor where I like to use it, too.)

Why worry about the small bugs in RM8, it still has major flaws, today it could not even import a tree from Ancestry with people still connected to their parents, my 3rd great-grandfather gained a new wife, and one daughter had her mother replaced with the new wife, thereby disappearing from the family group.
RM8 still freezes, crashes and otherwise fails.

Having been a Beta tester, and buying RM8 about a year ago, I now find I will have to pay again to get a workable version of Rootsmagic without even the option of a free trial, or a loyalty discount, and only one week to get the same discount as everyone else. There’s not even enough time for reviews to be published.
I wish I’d bought RM7.

I’m using the search function to find a person. If I type in the first name and the last name I have to move my mouse and click Find to get it to make a list. It doesn’t populate automatically as I type. It acts the same if I move to the Find Everywhere tab. I have to move my mouse to the Find button to make it work. I’m using v

They work in the Note Editor, but no longer work in data fields. You are forced to use right click menus and I can’t get any work done like this. Why is it that anytime ‘New Features’ are added, the old features seem to get broken?


In the edit window, delete a space or a letter and the blinking cursor disappears. You have to move the cursor with an arrow key or click somewhere with your mouse to bring it back. An annoyance, but it’s not right.

There is another one which I’m having trouble reproducing at the moment to describe it to you, but which was still there a day or so ago where when you delete something on a lower line, the cursor jumps to the end of the very first line of the edit window.

I just had one when I was searching for it. A line had not wrapped (not the fault of RM8, it was imported). I deleted the space at the end of the first line, which brought the 2nd line up to the correct place, but the cursor had disappeared. When I clicked with my arrow button to see it, it had jumped to the end of the entire line.

I just had another one. I was several lines down in a text and deleted a space to make lines wrap. The cursor as usual disappeared. It find it I hit the arrow key. This time it jumped to the beginning of the first line at the top of the file.

All of these this evening when searching for the bug that I had been able to reproduce for Renee several months ago were sporadic occurrences.

These little aggravations should be fixed. We bought the software believing that the bugs would be fixed and they haven’t been. I don’t disagree with the company’s release of a new version since it has new and desirable features for some, but fix the bugs in the old version before further development stops.

That’s the one I was looking for. It’s reproducible on my machine just now and I had reported this bug months ago. It’s the down arrow key that makes it jump to the top.

I also agree with your sentiment that RM8 is too mouse-centric. That really slows down data entry. Keyboard entry is faster - when it works.

Having been burned as a Mac user when I “upgraded” to RM8 from RM7, I ended up abandoning genealogy for a year. I have just learned that RM9 has been released. I am going to give this the benefit of the doubt and upgrade for $20 in order to get upgrades in the hope that the product eventually becomes stable.

In RM9, I tried to copy and paste a name from one individual to another. What I discovered is that - at least in the name field - Ctrl-A, Ctrl-C, and Ctrl-V do not work. I had to highlight the name with the mouse cursor, right click, choose “copy,” go to the other profile, highlight the name with the mouse cursor, right click, and choose “paste.” Another example of basic functions that disappear when an “upgrade” or “update” is released. Hopefully this will be fixed quickly.

A second problem, just found: When I use the “Search” function, located in the left margin, a specific name was “Not Found.” However, when I search for the same name in the “Index” section on the “People” tab, the name immediately pops up. This worked in RM8 (especially useful for finding women with their married name) but is now not working at all in RM9.

You might find an old RM7 cd online.

Although I STRONGLY agree that Ctrl-A, Ctrl-C, & Ctrl-V should work for cut/copy/paste, I was able to use Ctrl-Ins & Shft-Ins for cut/paste. Using mouse commands is NOT an acceptable alternative. RM8 and now RM9 seem to have taken a HUGE step back to using a lot of mouse actions instead of keyboard. The developers have seemed to have lost sight that most of us spend the most amount of time in the software doing data entry which is greatly inhibited when keyboard shortcuts are removed.

1 Like

Confirm the issue with Ctrl+A, Ctrl+C, Ctrl+V and Ctrl+X have been reported to development.