Latest update 8.1.8 and Ancestry TreeShare issues

I am now noticing that TreeShare indicates that many sources are showing Pink indicating that the source records in Ancestry and RM8 don’t match or need updating, but when I check these out there is no difference in them at all. This has only happened since the recent update to RM8.
I know that Ancestry will make some text changes to the Citation details (but no change to the actual record), but with this issue, this is not the case.

I’m seeing the same thing happening as well and its becoming a real pain to have to remove the extra citations ( if you except the non existent changes)

I have taken this up with Support and there doesn’t seem to be a solution, other than to create a new Database and download your Ancestry tree into it. I have done this and am now monitoring to see if this issue repeats itself.

To resolve an issue with some sources not uploading we needed to change the ID used when sharing sources/citations with Ancestry. That could be causing an issue in older Ancestry trees. If you are uploading a new tree, people or sharing sources you could see pink sources on the Person row, if the same source was used on a fact. You will also see a pink source on one of the spouses when adding family or marriage fact source.

In order to rid myself of these tedious pink entities I downloaded my Ancestry tree to a new rm database. It took time but with 40k records I knew it would and all went well and the pink items were gone as far as I could tell.
I did some research and did a Treeshare and the pink sources appeared when I expected them to do so. I then copied my file and tried an experiment and merged duplicate sources and then citations. The pink mence returned. The lesson seems to be don’t merge If you want to avoid a world of pain.

John
The only cases so far where I am still experiencing this issue after creating a new database is in regards to Marriage records.

I will also refrain from merging duplicate sources and citations in the hope that this will solve my concerns. Thanks for the tip.

To satisfy my own curiosity I downloaded my current Ancestry Tree into a RM7 database and found that the problems with sources that are affecting RM8 aren’t present, as far as I can tell, in RM7.

The new function in RM8 to “Merge all duplicate citations” is probably at the root of the problem because it compares only the values of the citation text fields and ignores the associated media and WebTags. Ancestry record sources from the same collection typically have identical citations despite having different media for different people. Merging those is ruinous ending up with one citation with one media for one person now applied to all the other people.

I think you are both onto something here. If RM7 doesn’t have this problem with TreeShare and that Merge Duplicate Citations is new to RM8, then it makes logical sense that this creates the issue. I assume therefore that Merge Duplicate Sources will not be a problem?

After making a lot of changes and additions to both RM8 and Ancestry data recently I have not encountered dual pink flags other than for Marriages, where there is no difference in the Source or Citation.

Merging all duplicate sources should not be a problem provided the name and field values of the Master Source clearly differentiate truly different sources. Once again, the merge function disregards differences in tagged media and WebTags or hidden AncestryIDs in TreeShare. So, be careful!

After converting a Rootsmagic 7 tree to RM8 I deleted the old Ancestry tree (first backing up both RM trees). When I uploaded my Rootsmagic 8 tree to Ancestry using treeshare the Ancestry tree shows the same source multiple times under “other Sources” although the Rootsmagic tree has only one entry. For example the 1930 census record appears four times in the Other Sources section on Ancestry. Ancestry Hints also include the 1930 census. The event fortunately appears only once.

This problem is not limited to shared facts. It also happened with a SSA Death Index with only name added to the original Ancestry tree.

Is there a way to clean this up and a way to avoid it in the future?

Thank you

It was not necessary and is likely inadvisable to delete your Ancestry Tree because the RM8 upgrade of your RM7 database would have remained linked to it. That might have avoided this situation where the Ancestry record for the 1930 Census which you had in RM7 has become a non-Ancestry record after uploading the upgraded database. I’m curious to know what happens when you upload from RM7 to a new Ancestry Tree. If that particular source flips to Other Sources for it as well, then it suggests that something changed on the Ancestry side to break the linkage between the Ancestry record and the citation in your databases.

EDIT: just noticed the reference to shared facts which is another complicating factor. And it’s possible that something was changed on your side to break the linkage. You are finding that most of your citations do end up in the new Ancestry Tree as Ancestry records?

Hi Tom,

Thank you for responding. The timing of deleting the Ancestry tree had more to do with the need to remove an entire branch of my tree including four generations when I discovered an early mistake. Ancestry does not make that in the least bit easy.

When I uploaded other RM7 trees to Ancestry the duplication problem never occurred except after being disconnected mysteriously from treeshare a year or so ago.

“You are finding that most of your citations do end up in the new Ancestry Tree as Ancestry records?” Yes, all of the ancestry records in the RM8 tree are shown as “Other Sources” in the new Ancestry tree. New Ancestry records are properly shown as Ancestry Sources.

Using the previous example of the 1930 census, the Ancestry Fact section indicating the sources shows only one entry for the 1930 census.

I have been having a lot of problems with this since the update. I manage my database locally with RM8 (previously RM7) and upload/sync changes to Ancestry. When I modify someone (even someone added since 8.1.8), I get pink boxes on sources (typically birth, baptism, death & burial), although when clicked they appear to be the same. TreeShare says there’s one new source so I update Ancestry and get two that appear to be the same. I delete the original one on Ancestry, re-check and it’s now ok. This way I can get rid of all the pink boxes EXCEPT on marriages. I have had problems with sources on marriages since I started with RM7, but I was always able to fix them by deleting the sources and marriages from both parties (on Ancestry), re-running TreeShare, and adding them again. Unfortunately this doesn’t seem to work with this issue and I now have a long list of changed people with pink boxes on their marriages. I’m very reluctant to re-upload a whole new tree to Ancestry because of my DNA common ancestors and the fact that I’ve shared my tree with several people. Anyone have any helpful suggestions?