Export data file (gedcom) errors

I created a .ged file from RM8 and uploaded it to MyHeritage. I received an error message and the upload was cancelled (tried this many times). I then created a gedcom file from Ancestry. This file was uploaded to MyHeritage successfully.

The RM8 gedcom file was 3.36 GB while the Ancestry gedcom was only 16 MB.

Why the difference in size and why the failure to upload the RM8 file?

  1. You are not actually uploading a GED or
  2. Something went horribly wrong

I have a 55MB file in RM8, it yields a 20MB Gedcom

Have you tried exporting again, and if so, I would suggest unchecking the RM specific boxes. Just for fun and giggles, can you open this 3.36 GB file in Notepad or whatever other plaintext editor that you might use? If so, do you see plaintext, or a bunch of odd symbols?

My rmtree file is 296 MB. I created another ged file and got the same result of 3.36 GB, so something is obviously wrong with this process.

Can’t open in any plain text editor as the file is too large.

There are lots of programs that will open large text files. A free one that you can use is Editpad Lite.

Tried that with no success. For some reason RM8 is producing a corrupt gedcom file. Not sure why I have this issue and no one else?

What’s your OS? On RM7, I advocated doing a periodic export to GEDCOM as a supplementary test to the Database Tools that could turn up an issue such as a lineage loop that the latter would not. That’s a problem in the data, not in the sqlite database integrity. In RM7, it would typically result in an error message. Our collective experience with RM8 is comparatively small and on an unstable platform.

Another powerful text editor is Notepad++. Probably needs to be a 64-bit app to operate on that size of file. Is the export filename suffix “.ged”?

Win 10 Pro. I’ve run all the database tools with no issues and yes the file is xxx.ged

Is the file an import from RM7? If so, does RM7 export successfully? If so, re-import directly from the .rmgc file to a new RM8 database and immediately export it again to rule out anything you may have done to the previous import.

No not an RM7 import. I created a new file and then downloaded everything from Ancestry. So no connection with RM7.

If you have RM7, download the tree with it and then export. If that works OK, then something is amiss with (the) RM8. The trick is in isolating the problem.

I ran an RM7 export of my existing tree and its file size was only 18 MB. I then started a new tree and opened up Treeshare to download my Ancestry tree and I keep getting a “Ancestry is not responding” message. On closing Treeshare RM7 then freezes. Treeshare works fine with RM8.

In rm7, check for updates. There was one released Oct 5 to fix an Ancestry access issue.

Thanks Tom, I missed that as I wasn’t aware that had been a problem with RM7.

Downloaded Ancestry Tree, created new gedcom file which was 33 MB.

So I now have the following from the same family tree and same parameters -

RM7 gedcom file 33 MB
Ancestry gedcom file 16 MB
RM8 gedcom file 3.36 GB

All very confusing?

I have been watching this thread with interest.
I have just over 70,000 people in my database (not all in my primary tree of relatives, some trees researched for cousins etc.
In RM8 the database file is about 159 MB, a GEDCOM exported with everyone and default options is about 111 MB. (The database was imported from RM7).
The same database file in RM7 is about 142 MB, a GEDCOM exported with everyone and default options is about 101 MB.
Either GEDCOM opens in GENViewer 2 in about 1 second.
In my main tree I have some first cousin marriages of ancestors.

Yes I think there is something causing a corruption in my RM8 file. I cannot open it in any text editor I’ve tried but the other 2 open very quickly in Wordpad.

I guess I may have to create another family tree file, download everything from Ancestry and then see what happens when I export that into a gedcom?

It’s probably just too large for the editors.

Did you import the fresh RM7 file into a new RM8 database and export from it, ending up with the >3GB file?

Just this minute tried an import from my new RM7 database, received an error message but the import seemed to work fine. I then created a gedcom file and this time successfully created a 40.6 MB file.

I guess now we know that the original RM8 database was corrupted somehow (but not picked up by the database tools) I should delete that and now use the new one?

Thanks all for your help.

Yes. Glad to hear the problem is resolved although the error you observed is concerning.

I should add that you should compare the database properties of the new rm8 database against those of the RM7 db from which it was imported.

I have done that and nothing untoward appeared other than about 10 people were showing in both db’s but were not matched. Not sure why that was so?

Oops just realised you meant to compare the properties, while I was comparing the 2 databases.

OK have just compared the file properties which are pretty much the same, given I have made some changes today.

1 Like