Website url display issue

I published a website with RM7 and when completed, the message displays:
“Your new site will be located at:

However, when I browse to that url it only displays browser error.
The only way I can reach the site with my internet browser (MS Edge) is at the following url:
" Streiff Family Ancestry "

Is that normal, or am I missing something?


I believe it’s normal… in the sense that it’s merely a notification box meant to be referring to its function access/origination (from within the program itself) as described in My RootsMagic See #3. (ie. That’s a way for “You” and only You to revisit/change/delete/etc. it via RM7).

Don’t use the “View this website” button in RM7. It won’t redirect properly. Click on the Gears (Website Settings) icon. It will open the correct link: Streiff Family Ancestry

Ok, that gets me to where the site pages are actually located, but it still doesn’t explain the misleading post-publish message which pops up and informs me that my new site will be located at: myrootsmagic . com/streiff. This turns out to be an incorrect url.

When my site is published, It seems I should instead get a message notifying me that my new site will be located at: sites . rootsmagic . com/streiff in order to avoid confusion.

You should. Once upon a time, the “View website” button did work. Then a change was made on the server or domain side and it no longer does. RM7 was never updated to fix it. I don’t remember if that happened before RM8 was released.

Edit: here’s a report from March 2021, six months before RM8 was released:

Edit #2: and another discussion from 2015 in which a user states that the website URL changed with the release of RM7 but the “View this website” control remained with the obsolete URL. And that is for the entire life of RM7…